5

On Ubuntu 16.04 LTS, I tried to install Minon Prop Latex package, which is a font, (for texlive) using this command: tlmgr install minionpro

But I got this error message:

(running on Debian, switching to user mode!)
/usr/bin/tlmgr: Initialization failed (in setup_unix_one):
/usr/bin/tlmgr: could not find a usable xzdec.
/usr/bin/tlmgr: Please install xzdec and try again.
tlmgr: Couldn't set up the necessary programs.
Installation of packages is not supported.
Please report to texlive@tug.org.
Use of uninitialized value $r in split at /usr/bin/tlmgr line 3882.
tlmgr: Cannot find main repository, you have to tag one as main!

How can I fix this?

  • are you sure that you don't need super user privileges? What about sudo tlmgr install minionpro? – Alessandro Cuttin Dec 2 '16 at 15:19
  • I run tlmgr init-usertree previously to that. But just to be sure, I run the above command again after sudo but I got exactly the same error @AlessandroCuttin – steve Dec 2 '16 at 15:21
  • Are you using the LaTeX distribution provided by Ubuntu? Debian (except unstable) and Ubuntu are not up to date with TeX Live. I would recommend installing TeX Live directly from TUG instead of using the Debian packages. – Alessandro Cuttin Dec 2 '16 at 15:26
2

You are using the TeX Live distribution as shipped by Debian, that means tlmgr only works in user-mode. After you have set up the user tree as you have described, you should be able to first set the remote repository with tlmgr option repository URL, and then install the required packages with tlmgr install PKG.

| improve this answer | |
1

The error tells you that xzdec in not installed. Try using:

sudo apt-get install xzdec

As this resolved the issue for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.