2

I installed Tex Live 2016 on Ubuntu 16.04.1 LTS using

sudo apt-get install texlive-full

Now References are not working. MWE is below with its output:

\documentclass{article}
\usepackage[style=authoryear]{biblatex}
\bibliography{myrefs}
\begin{document}
\textcite{lamport94} is a good reference for \LaTeX.\\
Main matter with citations such as \autocite{lamport94}.
\printbibliography
\end{document}

enter image description here

The contents of myrefs.bib are:

@book{lamport94
, author    = "Leslie Lamport"
, title     = "{\LaTeX} : a document preparation system"
, edition   = "2nd"
, publisher = "Addison-Wesley"
, year      = 1994
}

If I run other documents which was working correctly, I get the following error messages:

This is BibTeX, Version 0.99d (TeX Live 2016/Debian) The top-level auxiliary file: Test.aux I found no \citation commands---while reading file Test.aux I found no \bibdata command---while reading file Test.aux I found no \bibstyle command---while reading file Test.aux (There were 3 error messages)

I also installed biber using

sudo apt-get install biber

But, no success. Even references are not working in LYX 2.2.2 with its template documents. Any help to figure out the problem will be highly appreciated. Thanks in advance for any help.

  • 1
    To use the bibtex backend with biblatex you need to pass the backend=bibtex option to biblatex. The generally preferred backend for biblatex is biber though - what do you mean by no success? What did you try/where did things go wrong? – Dai Bowen Dec 3 '16 at 15:49
  • Thanks @DaiBowen for your comment. Yes, I used \usepackage[backend=bibtex, style=authoryear]{biblatex}, but still the same problem. I want to use biber, I thought it might be missing so I installed it but even after that, I am getting the same error. BWT biber is used in biblatex. Any thoughts, please. – MYaseen208 Dec 3 '16 at 15:55
  • 1
  • @MYaseen208 You've got a TeX example but mention LyX: I'm not sure quite how you are working. In the .tex file example, running latex <filename> then biber <filename> should give you a .blg file: does it work and are there any errors? – Joseph Wright Dec 4 '16 at 8:04
  • Thanks @JosephWright for your comment. I am using Tex and also tried the same thing in LYX and both are not working. Any thoughts. Thanks – MYaseen208 Dec 4 '16 at 9:21
0
  1. Use kpsewhich biblatex.sty to get /usr/share/texlive/texmf-dist/tex/latex/biblatex/biblatex.st‌​y.
  2. From SourceForge download biber v.2.6.
  3. From SourceForge download biblatex v.3.6
  4. Create two temp dirs: mkdir tempbb && mkdir tempbl
  5. Uncompress biber-cygwin64.tar.gz and biblatex-3.6.tds.tgz to the temp directories:

    tar -zxvf biber-cygwin64.tar.gz -C tempbb/
    tar -zxvf biblatex-3.6.tds.tgz -C tempbl/
    
  6. Move the contents of the files in the tempbl temp directory to /usr/share/texlive/texmf-dist/ thus:

    sudo rsync -azvv tempbl/ /usr/share/texlive/texmf-dist/
    
  7. Move the biber bin from your temp directory to /usr/share/texlive/ thus:

    sudo rsync -azvv tempbl/ /usr/share/texlive/
    
  8. Run mktexlsr
  9. Test that everything is working fine.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.