2

I am using BibLaTeX, ibidem tracker and referencing in footnotes. The problem is, when I put a reference (\cite) inside a footnote, the ibidem tracker seems to ignore this reference. So, whenever there is the next reference outside of the footnote, mistakenly this reference might be replaced by "ibid" even though it is not the same as the previous reference found in the footnote.

It does work correctly if I use \autocites instead of citing within a footnote, but I don't want to do this, as I have lengthy footnotes with several quotes and it is inconvenient to put all the text in pre-/postnotes.

Edit: The issue seems to occur when I use polyglossia with an alternative language that has RTL script (such as Hebrew or Arabic). It doesn't matter whether the RTL language is actually used in the document or not, so it seems that package configurations are interfering.

This is my MWE:

\documentclass{scrreprt}

\usepackage{polyglossia}
\setdefaultlanguage{english}  % or other LTR language
\setotherlanguage{hebrew} % or other RTL language (arabic)
\usepackage[style=authortitle-icomp, backend=biber, autocite=footnote, idemtracker=constrict, opcittracker=constrict, loccittracker=constrict, citetracker=context]{biblatex}
\begin{filecontents}{\bibliography.bib}
@book{Doe2002,
    author = "John Doe",
    location = "New York",
    publisher = "Springer",
    shorttitle = "Wheel",
    title = "The Invention of the Wheel",
    year = "2002"
}

@book{Smith2004,
    author = "John Smith",
    location = "Boston",
    publisher = "Bookhouse",
    title = "Paradigm Shift",
    year = "2004"
}
\end{filecontents}
\addbibresource{\bibliography.bib}
\begin{document}
Reference 1 to Doe\autocite[See][258]{Doe2002}.

Text and footnote references.\footnote{\cite[See][36]{Smith2004} and also \cite[see][187--195]{Doe2002}.}

%Text and cites references.\autocites[See][36]{Smith2004}[and also][187--195]{Doe2002}

Text and reference 3 (to Doe).\autocite[See][258]{Doe2002}
\end{document}

I would expect the following references:

  • See Doe 2002 (p. 258)
  • See Smith 2004 (p. 36), See Doe 2002 (p. 187-195)
  • See Doe 2002 (p. 258)

However, what I get is this:

  • See Doe 2002 (p. 258)
  • See Smith 2004 (p. 36), See Doe 2002 (p. 187-195)
  • See ibid.

So, the last reference is only "ibid" without specifying a page number. Thus, it mistakenly refers back to the very first reference, ignoring the references in the footnote.

Do you know how this can be fixed? I am using XeTeX 3.1415926-2.5-0.9999.3-2014012222 (TeX Live 2013/Debian) and biber 1.8.

This person seems to have had a similar problem, though for a different reason (combining BibLaTeX with memoir):

Difference between \footcite and \cite in BibLaTeX

  • 2
    Your example doesn't give the output that you say that it gives, which makes it harder to help. But anyway, why do you have a lot of "context" and "constrict" options that tracks footnotes and body text separately. Isn't this what you are trying to avoid? – pst Dec 3 '16 at 22:33
  • As pst notes, with a up-to-date installation the output of your MWE is different. Please update your question to make sure the output of your code matches with what you claim it shows. I get "ibid" with a page number, for example. Furthermore, all citations are in footnotes in your example, so I don't understand why the last "ibid" would mistakenly refer to the first citation? – moewe Dec 4 '16 at 11:47
  • Sorry, I have now corrected the MWE. The issue only seems to come up when the line \setotherlanguage{hebrew} is present - no matter if I actually use Hebrew in the document or not. I can also replace Hebrew with Arabic and it's the same thing, which makes we think it is an RTL issue. If I change the line to \setotherlanguage{french}, everything works correctly. – greektex Dec 6 '16 at 17:07
  • @pst This is a very good point. I changed the trackers to "strict" which solved the problem. – greektex Dec 6 '16 at 17:16
  • 1
    You get a warning: 'Patching footnotes failed. Footnote detection will not work.' This seems to be bug problem with biblatex: github.com/plk/biblatex/issues/412, see also tex.stackexchange.com/q/229182/35864 – moewe Dec 6 '16 at 17:30
2

This issue has now been fixed in biblatex 3.8. You should now get proper tracking of citations within footnotes for RTL languages. See https://github.com/plk/biblatex/pull/576 for details.

MWE:

\documentclass{article}
\usepackage{polyglossia}
\usepackage{csquotes}
\setdefaultlanguage{english}
\setotherlanguage{hebrew}
\usepackage[style=authortitle-icomp]{biblatex}
\begin{filecontents}{\jobname.bib}
@book{Doe2002,
  author = {John Doe},
  location = {New York},
  publisher = {Springer},
  shorttitle = {Wheel},
  title = {The Invention of the Wheel},
  year = {2002}
}
@book{Smith2004,
  author = {John Smith},
  location = {Boston},
  publisher = {Bookhouse},
  title = {Paradigm Shift},
  year = {2004}
}
\end{filecontents}
\addbibresource{\jobname.bib}
\pagestyle{empty}
\parindent 0em
\begin{document}
\null\vfill
\verb+\autocite+ to Doe\autocite[See][258]{Doe2002}.

\verb+\autocites+ to Smith and Doe \autocites[See][36]{Smith2004}[and
also][187--195]{Doe2002}.

\verb+\autocite+ to Doe \autocite[See][258]{Doe2002}.

\verb+\footnote{\cite+ to Smith and \verb+\cite+ to
Doe\verb+}+.\footnote{\cite[See][36]{Smith2004} and also
\cite[see][187--195]{Doe2002}.}

\verb+\autocite+ to Doe\autocite[See][258]{Doe2002}.

\verb+\footnote{\cites+ to Smith and
Doe\verb+}+.\footnote{\cites[See][36]{Smith2004}[and
also][187--195]{Doe2002}.}

\verb+\autocite+ to Doe\autocite[See][258]{Doe2002}.

\end{document}

enter image description here

  • tex.stackexchange.com/q/229182/35864 is about the same problem. Do you want to answer there as well or close as a duplicate? – moewe Nov 16 '17 at 8:55
  • I can confirm this second one works fine now. I think close it as a duplicate. I don't have enough reputation to do this though. – David Purton Nov 16 '17 at 13:25
  • Unfortunately, I can't vote to close either (voted to close an earlier unclear version of the question). Maybe we need to ask someone else. – moewe Nov 16 '17 at 17:25
  • OK. I'll give an answer. – David Purton Nov 16 '17 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.