0

I have a problem with the package glossaries. I am trying to generate a glossary list (\newacronym...) but TeXnicCenter does not print it in the final document. It says that entries have been read and writen in the output file .gls but the pdf document does not include it.

MakeIndex has been configured as follows: "%tm.acn" -s "%tm.ist" -o "%tm.gls"

My main file contains the document definitions but I have all setting in a new TeX document which is "called" by the main file.

enter image description here enter image description here Thanks you in advance!


Additional information about the Build Output Messages:

enter image description here

  • 3
    Welcome to TeX.SX! Please post code as text rather than images.so it can be copied and compiled readily. Similarly if you can distill your code into a minimal working example (MWE) i.e. with no unnecessary packages, no \input or \include commands but just the minimum code required to replicate your problem that makes it easier for us to see what is wrong and offer assistance. – Dai Bowen Dec 3 '16 at 20:14
  • it works, thanks you very much. The problem was the .gls file. I have change the extension to .acr and everything is fine now. THANKS YOU! – Pablo Cosio Dec 3 '16 at 23:46
1

Usually the makeindex output for acronyms goes to a .acr file, not a .gls file. The latter one is for "other" glossary entries. So use "%tm.acn" -s "%tm.ist" -o "%tm.acr". Or even better, use the makeglossaries perl script if you have it.

0

I have had the best results by running a batch file after using MiKTeX. Within the file_name.bat file (created and saved in the plain text editor or your choice):

makeindex file_name.glo -s file_name.ist -t file_name.glg -o file_name.gls
makeindex file_name.acn -s file_name.ist -t file_name.alg -o file_name.acr

If you are only making a glossary and not using another file for acronyms, you can eliminate the second line.

  • This doesn't really answer the question, since it doesn't address the issue the OP is having. – Werner Jan 3 '17 at 18:19
  • As @PietvanOostrum pointed out, the wrong file extensions are called out in the OP's attempt to use \makeglossaries. Changing the request will correct the error. Another option, as stated previously, is to run this set of files externally—and running makeindex via an external batch file accomplishes that goal without needing the pearl script. – Tavrock Jan 3 '17 at 18:57
  • If you don't want to use the Perl script, there's a Lua alternative makeglossaries-lite.lua which will find the extensions from the .aux file (and determine whether makeindex or xindy needs to be run). – Nicola Talbot Jan 3 '17 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.