1

I'm having some trouble getting Miktex to correctly include some fonts in my document. The document compiles correctly over linux (texlive 2015) but when I run it over windows (miktex 2.9) it turns the MnSymbol fonts into type 3 fonts. This caused the library to reject the file for my PhD thesis (since it shows up as not having embedded fonts), so I would like to fix this, ideally without having to recompile over linux.

A minimal working example is as follows:

\documentclass{report}

\DeclareFontFamily{U} {MnSymbolA}{}
\DeclareFontShape{U}{MnSymbolA}{m}{n}{
  <-6> MnSymbolA5
  <6-7> MnSymbolA6
  <7-8> MnSymbolA7
  <8-9> MnSymbolA8
  <9-10> MnSymbolA9
  <10-12> MnSymbolA10
  <12-> MnSymbolA12}{}
\DeclareSymbolFont{MnSyA} {U} {MnSymbolA}{m}{n}
%
\DeclareMathSymbol{\rcirclearrowright}{\mathrel}{MnSyA}{248}
\DeclareMathSymbol{\lcirclearrowright}{\mathrel}{MnSyA}{252}
%

\begin{document}

$\rcirclearrowright$, $\lcirclearrowright$

\end{document}

The funky loading of MnSymbol was written as described in this thread, and it is required because the thesis is pretty bulky and, if I try to include the MnSymbol package directly, I get a "too many alphabets" error.

If I compile this over miktex, I get a C:/Program Files/MiKTeX2.9/fonts/type1/public/ amsfonts/cm/cmr10.pfb font, which is pretty standard, but I also get a type 3 font, C:\Users\ episanty\AppData\Local\MiKTeX\2.9\fonts\pk\ljfour\public\mnsymbol\dpi600\MnSymbolA10.pk. This is marked by Adobe Reader as a non-embedded font:

This answer suggests that simply installing the package in the Miktex Package Manager should fix the problem. However, the only action that Miktex offers me with respect to the MnSymbol package is uninstalling it, which I don't think will help.

How can I persuade miktex to embed this properly as a type 1 font?

2

It happens MiKTeX forgets to launch updmap after it installed font files. Thus the type 1 fonts databases (psfonts.map and friends) are not updated. Normally, all you have to do is to run updmap --verbose as administrator.

  • Well, I'll be. That's possibly the weirdest problem/solution pair I've come across TeX-side. Worked like a charm. – E.P. Dec 3 '16 at 20:35
  • Miktex doesn't forget it. But if you installed fonts as user you then have user maps. – Ulrike Fischer Dec 3 '16 at 21:37
  • @Ulrike Fischer: It happens MiKTeX doesn't run updmap. I could observe it several times. Everything I've installed is as Administrator. – Bernard Dec 3 '16 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.