1

Since moving to TeXLive 2016 I'm unable to use microtype with the MinionPro package. Here's a MWE, which compiles just fine with TeXLive 2015:

\documentclass{article}
\usepackage{microtype}
\usepackage{MinionPro}

\begin{document}
    Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod
    tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,
    quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo
    consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse
    cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non
    proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
\end{document}

When I try running this through pdfLaTeX, I get a font expansion error:

pdfTeX error (font expansion): auto expansion is only possible with scalable fonts.
Check the TeX log file for more information

I suspect the problem is due to an out-of-date microtype configuration file. If so, what's the easiest way to fix that? (Getting Minion Pro to work with LaTeX was quite a headache, so if possible I'm looking for a way to avoid having to do it all over again.)

(If not, what else could be going on?)

  • Remove microtype, compile with pdflatex and then show what fonts this is using (see the list at the end of the log-file). – Ulrike Fischer Dec 5 '16 at 19:38
  • I'm not sure I understand the question, but there seems to be a problem with my font files and TeXLive 2016. When I run compile without microtype I also get an error message: Font MinionPro-Regular-osf-ot1--base at 545 not found – apc Dec 5 '16 at 22:20
  • What should I be looking for in the log file? – apc Dec 5 '16 at 22:23
  • 4
    In general this means that you haven't enable the map file. Does it work if you add \pdfmapfile{=MinionPro.map} to your document? – Ulrike Fischer Dec 5 '16 at 22:45
  • 2
    Normally you should be able to add the map-file permantly with updmap-sys --enable Map=MinionPro.map. – Ulrike Fischer Dec 5 '16 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.