3

I am trying to make my first submission to arXiv. I have a document with multiple include modules and images. When arXiv compiles it, it throws a lot of output, the major error being:

! LaTeX Error: Unknown option 'nameinlink' for package 'cleveref'.

Needless to say that the document compiles no problem on my machine.

I will write the document preamble here, perhaps it is of any help

\documentclass[a4paper,11pt]{article}

\usepackage[sort&compress,super]{natbib}
\usepackage[T1]{fontenc}

\usepackage[english]{babel}
\usepackage{amsmath, esint}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{tabularx}
\usepackage{caption}
\usepackage{subcaption}
\usepackage{url}
\usepackage{array}
\usepackage{algorithm,algorithmic}
\usepackage{tikz}
\usepackage{url}  
\usetikzlibrary{arrows}
\usetikzlibrary{mindmap,trees}
\usepackage[overlay,absolute]{textpos}
\usepackage{wrapfig}
\usepackage{makeidx}
\usepackage{listings}
\usepackage{color}
\usepackage{xcolor}
\usepackage{enumitem}
\usepackage[normalem]{ulem}
\usepackage{mathtools}
\usepackage{lscape}
\usepackage{hyperref}
\usepackage{cleveref}

\usepackage{mdframed}
\definecolor{mycolor}{rgb}{0.122, 0.435, 0.698}

Please help

EDIT

Removing [nameinlink] from cleveref brings me one step further:

! LaTeX Error: Option clash for package hyperref.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...

l.107 \begin
{document}
?
! Emergency stop.
...

EDIT 2

Sorry, I forgot the mdframed in the original post

6
  • typically it's just because they have an old tex distribution and presumably the cleverref package didn't have that option then, simplest if you do not need it is simply to remove [nameinlink] Dec 7, 2016 at 14:09
  • Welcome to TeX.sx! Please give a minimal working example (MWE).
    – strpeter
    Dec 7, 2016 at 14:10
  • Hey strpeter, I am afraid that a minimal working example will require me two hours of uploading different files to arxiv system, sorry Dec 7, 2016 at 14:18
  • that's odd in the code you show you only load hyperref once and with no options, the h text of that message shows exactly which option is clashing I'm not sure if you can get that back from arxiv? otherwise perhaps there system adds hyperref in which case you could simply comment out your \usepackage{hyperref} Dec 7, 2016 at 15:47
  • 1
    I've had exactly this problem with several arXiv submissions, and I'm pretty sure it's because (as David Carlisle speculates) they have an outdated version of cleveref. The simplest solution is to include an up-to-date cleveref.sty as one of the files in your submission. Dec 7, 2016 at 22:34

1 Answer 1

2

I have found the solution here.

Option clash with hyperref

The answer is to completely ignore hyperref errors and ensure that all of the other errors - e.g. missing pictures are in place. If the above error is the only error in the document, it compiles nevertheless

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .