1

Using package pdfpages from 2016 (pdfpages 2016/04/19 v0.5f) with addtotoc-option yields problems which do not arise with pdfpages-Package from 2002 (pdfpages 2002/10/01 v0.2k). Here is a minimal working example:

\documentclass[a4paper]{article}
\usepackage{pdfpages}
\pagestyle{empty}
\begin{document}
\tableofcontents
\includepdf[pages=1-12,nup=2x2,addtotoc={
1,section,1,Filme auf Festplatte U,U,
1,subsection,2,U001,U001,
7,subsection,2,U007,U007
}]{input.pdf}
\end{document}
  1. Using 2002-version all works fine: Apart from table of Contents there are 3 Sheets of Output, each containing 4 pages of Input and correct links in the table of Contents.

  2. Using the 2016-version of pdfpages gives the following Output (for the above example):
    Table of Contents
    First output-sheet contains input-page 1 in upper left corner, rest is blank.
    Second output-sheet White space in upper left corner and then page 2-4 at correct Positions.
    Third output-sheet contains input-pages 5-7, lower right Corner is blank and fourth Output-sheet contains only page 8 in lower right Corner.
    Rest is oK.

Obviously there is a pagebreak after each entry from addtotoc-Option which doesn't makes sense - in my honest opinion.
The above example should work with any input.pdf containing at least 12 pages. Thanks for help, N. Klingen

  • Welcome to TeX.SX! Please, add a minimal example. – Heiko Oberdiek Dec 10 '16 at 21:19
  • I think an MWE would be helpful. And perhaps a pointer to where the 2002 package may be found. What version is the 2002 one? It seems the most recent is 'only' 0.5f.... But I don't have a copy of the earlier versions anymore. – jon Dec 10 '16 at 21:20
  • 1
    The change is much more recent than 2002. Using my archive if TL releases, I am fine with the ('final update') TL'14 one (pdfpages 2013/08/25 v0.4v) but not with the TL'15 one (pdfpages 2015/09/18 v0.5d). I'll try to get a diff for this. – Joseph Wright Dec 11 '16 at 10:05
  • 1
    The issue seems to appear between v0.4w and v0.4x (tug.org/svn/texlive/trunk/Master/texmf-dist/tex/latex/pdfpages/…) – Joseph Wright Dec 11 '16 at 10:22
3

The issue appears between v0.4x (2015-05-11) and v0.4w (2015-04-15): the TeX Live SVN shows us a diff. This is not a 'simple' change, and with no change log or other info it's not immediately obvious where the problem is. As a temporary work-around, I suggest using the latest working version of the code from the TeX Live SVN. (Version v0.4w seems to have an unrelated issue which means I'd go with v0.4v here.) For a long-term fix, this needs attention from the package author: I have reported it by email.

  • Thanks for the comprehensive answer. I always found it hard go obtain older versions. – Dr. Manuel Kuehner Dec 11 '16 at 10:55
  • 1
    @Dr.ManuelKuehner Depends on the package and the timeframe. The TeX Live SVN is good for the past ~10 years, before that there are yearly snapshots. For LaTeX itself, our SVN goes back a long way ... – Joseph Wright Dec 11 '16 at 11:17
  • @JosephWright Thanks for the thourough Analysis of the Problem. As work-around I used the old Version of pdfpages, it worked fine, but I thought it might be useful for the community to know of this Problem because pdfpages is an extremely useful package. – Norbert Klingen Dec 11 '16 at 14:38
  • @Joseph Wright and the package-maintainer: I just updated MiKTeX which contains pdfpages 2016/12/11 v0.5g. Now my problem is completely solved, my old source files work as ever before. Many Thanks to all those involved in updating the system!! – Norbert Klingen Dec 27 '16 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.