0

I recently decided to use biblatex instead of bibtex to do my citations. One of the problems I have been facing is that the urls for the webpages are not showing up in my bibliography. First time I tried running it, an error message asked my to include the hyperref package. I did that and it executed but the bibliography had "Web" written at the end and it was linked to the url. I switched the hyperref package with url, hoping it would change the "Web" to the actual url. instead, it kept the "Web" and now its not even linked to the webpage. What I want is for the full url to be displayed and for that to be linked to the webpage. Is it possible to do this? If so, can someone please help me out?

*note: I am using the mla style for everything

EDIT Here is the MWE:

This is the latex code:

\documentclass[12pt]{article}

\usepackage{graphicx}
\usepackage{indentfirst}
\usepackage{csquotes}
\usepackage{float}
\usepackage{setspace}
\usepackage{url}
\usepackage{hyperref}
\usepackage[font=footnotesize]{caption}
\usepackage[font=footnotesize]{subcaption}
\usepackage[backend=biber,style=mla]{biblatex}

\urlstyle{sf}
\addbibresource{test.bib}

\begin{document}

    Some sample text.\cite{test}

    \printbibliography

\end{document}

and this is the the bib file:

@online{test,
    author = {Sample Author},
    title = {Sample Title},
    journal = {Sample Journal},
    date = {2016-12-14},
    url = {http://www.sample.com}
    }
  • 2
    Welcome to TeX.SX! If you can provide an MWE we will be bale to reproduce your problem more efficiently and investigate it in more detail. – moewe Dec 13 '16 at 19:29
  • Update biblatex-mla and use the new style=mla-new. – moewe Dec 14 '16 at 7:40
  • If you use the old style, try the option noremoteinfo=false. – moewe Dec 14 '16 at 7:46
  • I tried adding 'noremoteinfo=false'. It puts the link in but it also keeps the the word "Web" and it puts the link in between "<" ">". This is not the standard mla citation format. My school won't accept it. – Pranav Dec 15 '16 at 4:19
  • This probably was MLA v. 7. If you want the newer version 8 (where the output probably looks like you want), you need to update biblatex-mla and use mla-new. – moewe Dec 15 '16 at 9:18
1

You seem to want to follow the 8th edition of the MLA style. In order to use this style you will have to update your biblatex-mla package and use the new style mla-new

\documentclass[12pt]{article}
\usepackage{csquotes}
\usepackage{float}
\usepackage[backend=biber,style=mla-new]{biblatex}
\usepackage{hyperref}

\urlstyle{sf}
\addbibresource{biblatex-examples.bib}

\begin{document}
  Some sample text.\cite{ctan}

  \printbibliography
\end{document}

example output


In the old style mla which follows the 7th edition, you can use the option

noremoteinfo=false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.