1

I'm building a beamer using

TeXstudio 2.10.8 (5802:5ee1d048e556)

Ubuntu 16.04

and i need to see a video in my beamer. This it's the way i used:

...
\usepackage{multimedia}    
...
%FOUNDED IN INTERNET AND DON'T REMEMBER URL (STACKOVERFLOW)
\begin{frame}{movie}
    \begin{figure}[h!]
        \centering    
        \movie[label=show3,width=1.0\textwidth,poster
        ,autostart,showcontrols=true,loop] 
        {\includegraphics[width=1.0\textwidth]{images/image1.jpg}}{video/video1.mp4}
        \caption{caption}
    \end{figure} 
\end{frame}

but texstudio show me this message:

You clicked on a video, but the video playing mode was disabled by you or the package creator.

Recompile Texstudio with the option PHONON=true

later, in options-> Configure Textstudio, tab Commands i put PHONON=true param in the command PdfLatex

for this case, in the process of compiling, only can see in my console

Process started: pdflatex -shell-escape -synctex=1 PHONON=true -interaction=nonstopmode "main".tex

for two hours do nothing, what is wrong

the size of my video is 1.2 mb

thanks in advance...

  • Thank you for posting a working example! At the same time, much of your code does not seem to be relevant to the question you're asking here. Please limit the example to only the code required for your issue to appear. You can have a look at this guide for how to prune your code for this purpose. – Martin Schröder Dec 14 '16 at 6:26
  • @MartinSchröder: thanks for you recomendation, i'll have in mind – Orlando Yero Dec 14 '16 at 16:52
4

The message to use the PHONON option refers to compiling your editor and viewer, not compiling your document.

The documentation for the media9 package states that embedded media can only be viewed using Adobe Reader (specific versions only) or Foxit Reader. (See §2, p.3 of the attached documentation.)

The documentation for the multimedia package (§14.1.1, pp.133-134) states that

Whether the viewer application can actually display the movie depends on the application and the version. For example, the Acrobat Reader up to version 5 does not seem to be able to display any movies or sounds on Linux. On the other hand, the Acrobat Reader Version 6 on MacOS is able to display anything that QuickTime can display, which is just about everything. Embedding movies in a PDF document is provided for by the PDF standard and is not a peculiarity of the Acrobat Reader. In particular, one might expect other viewers like xpdf and poppler-based viewers (Okular, Evince) to support embedded movies in the future.

...

If your viewer application is not able to render your movie, but some external application is, you must use the externalviewer option. This will ask the viewer application to launch an application for showing the movie instead of displaying it itself. Since this application is started in a new window, this is not nearly as nice as having the movie displayed directly by the viewer (unless you use evil trickery to suppress the frame of the viewer application). Which application is chosen is left to the discretion of the viewer application, which tries to make its choice according to the extension of the ⟨movie filename⟩ and according to some mapping table for mapping extensions to viewer applications. How this mapping table can be modified depends on the viewer application, please see the release notes of your viewer.

Again, the problem is with your PDF viewer, not with *TeX.

  • sorry, the package is multimedia, no media9 (\usepackage{media9} was a test at some point) – Orlando Yero Dec 14 '16 at 0:09
  • 1
    @OrlandoYero: Stop wasting our time and post an MWE that demonstrates your problem. – Martin Schröder Dec 14 '16 at 6:27
  • @MartinSchröder: i don't have full time internet, sorry, now traying to change my pdf viwer – Orlando Yero Dec 14 '16 at 16:55
  • 1
    @MartinSchröder: solved my problem i changed to okular – Orlando Yero Dec 14 '16 at 17:04
0

I have the same problem as you and I also use Ubuntu 16.04. I solved the problem by opening the pdf file with the okular program

sudo apt-get update sudo apt-get install okular

  • This is at best a comment IMHO. – user121799 May 3 '18 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.