0

This question already has an answer here:

I have a UTF8 workflow: xelatex, using biblatex and biber for the bibliography, and I think I have come across a funny behaviour from biber. It seems to be converting silently to a percent-coding string (no trace in any log) a URL that contains one single non-ASCII character.

See the MWE with output. The URL contains one simple ü, which is being converted to %C3%BC. I would expect and wish the URL to be kept as it is. Can you spot any mistake? As you can see I've tried the biblatex options that affect biber's, but nothing seems to work, I still get the bloody %C3%BC.

Just in case, I manage my .bib file with BibDesk and I've checked it is saved as UTF8 too.

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode
\documentclass{article} 
\usepackage{fontspec}
\usepackage[backend=biber,bibencoding=utf8,texencoding=utf8,safeinputenc=false]{biblatex} 
\usepackage{filecontents}

\begin{filecontents}{bib.bib}

@online{verknupf_expo2016,
Author = {{Warburg Institute}},
Title = {Exhibition: \emph{Verknüpfungszwang}},
Url = {http://warburg.sas.ac.uk/exhibition-verknüpfungszwang},
Urldate = {2016-12-12}}

\end{filecontents}
\addbibresource{bib.bib}
\nocite{*}

\begin{document} 
Hello and bla bla bla bla bla bye

\printbibliography
\end{document}

output of above MWE

I've checked that the .bib file contains the unicode alright, but it has been converted in the .bbl

marked as duplicate by moewe biblatex Dec 19 '16 at 8:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    With the newest biber (2.7) you can use the option ` --nouri-encode` – Ulrike Fischer Dec 15 '16 at 16:58
  • Ulrike you're a star. Is there a way to pass this biber option from the tex file? – Juan del Acebo Dec 15 '16 at 17:08
  • I don't think so. The option is shiny new (and undocumented ...). But you could make a feature request. github.com/plk/biblatex/issues – Ulrike Fischer Dec 15 '16 at 17:32