5

Below is a MWE. I can't get glossaries to appear in any of my documents and I think it has something to do with the way my TexStudio is configured. I'm using the most up to date TexLive and TexStudio in Linux Mint 18.

\documentclass   [11pt, a4paper, oneside]{book}
\usepackage[acronym, toc]{glossaries} 

\makeglossaries
\newacronym{gdp}{GDP}{guanine diphosphate}

\begin{document}
\gls{gdp}

\printglossary[type=\acronymtype]

\end{document}

Here are the PdfLaTex and Makeglossaries commands in my TexStudio configuration (I have a folder in the root directory where the output files are saved, called Misc):

PdfLaTex: pdflatex -synctex=1 -interaction=nonstopmode  --output-directory=./Misc %.tex

Makeglossaries: makeglossaries %

Here are my build commands:

Build & View: txs:///compile | txs:///index | txs:///glossary | txs:///compile | txs:///view

Default compiler: txs:///pdflatex

Default Glossary Tool: txs:///makeglossaries

This simply gives me a warning that says "No file .acr" and doesn't print the glossary. What am I doing wrong?

3 Answers 3

1

Your output files are written to the Misc directory, including the files that makeglossaries needs (.aux and .acn). However, makeglossaries doesn't know that. So you must tell it in your configuration -d Misc in the makeglossaries entry. Other entries would also have to be adapted, like makeindex, viewer, etc.

3
  • Thank you for your answer. So I tried this, in the command for Makeglossaries: "makeglossaries -d Misc %" (without quotes) but still no glossary. Is that what you meant? Dec 15, 2016 at 22:17
  • Yes, that's what I mean. Actually, on my system it is a bit more involved, like sh -c "PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/texbin/; makeglossaries -d Misc %" What Messages do you get. You can also try Tools > Glossary and see what messages come out of it. Dec 15, 2016 at 22:36
  • Ah thank you, by doing the above I was given an extremely helpful error message reminding me to pass the "nomain" option to glossaries if I was not using a main glossary (just acronyms). Once I did this, your help with setting "-d Misc" worked like a charm. Dec 16, 2016 at 9:42
1

I managed to solve this problem on my Debian system with TeXstudio by changing the "Default Compiler" entry (reachable via Options->Configure Texstudio->Build) from

txs:///pdflatex

to

txs:///makeglossaries | txs:///pdflatex

and compiling the document with the F6 shortcut afterwards. See the attached screenshot as well:

Texstudio configuration

0

If you are running makeglossaries from the command line make sure that you don't use any extension, e.g. if your main latex file is called my_project.tex, then you need to run:

makeglossaries my_project

In this way, it will generate "all glossaries". From makeglossaries output:

"either omit the extension to make all the glossaries, or specify one of the glossary files, e.g. test_acronym.tex.glo, to make just that glossary."

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .