0

I am struggling with this error:

Unfortunately, the package unicode-data could not be installed. Please check the log file: C:/Users/G/AppData/Local/MiKTeX/2.9/miktex/log/pdflatex.log

Error: Command crashed: pdflatex.exe -synctex=1 -interaction=nonstopmode "icml_paper".tex

The MiKTeX Package Manager tries to install a package but fails, otherwise the compilation goes through and I can see the resulting PDF document, which looks fine.

This happens every time I am compiling a ".tex" file with asymptote drawing in the document. But it seems as though it is not directly related to asymptote (since compiling asymptote drawing by running asym, works fine).

I get the following log message in pdflatex.log:

  • 2016-12-16 15:39:57, 763-0500 INFO pdflatex - installing package unicode-data triggered by tex\generic\unicode-data\UnicodeData.txt

  • 2016-12-16 15:39:59, 580-0500 INFO pdflatex - mpm: starting package maintenance...

  • 2016-12-16 15:39:59, 581-0500 INFO pdflatex - mpm: installation directory: " "
  • 2016-12-16 15:39:59, 581-0500 INFO pdflatex - mpm: package repository:
    http://ftp.math.purdue.edu/mirrors/ctan.org/systems/win32/miktex/tm/packages/
  • 2016-12-16 15:39:59, 768-0500 INFO pdflatex - mpm: lightweight database digest: 821702480171a06b6df4bdf9211b13e8
  • 2016-12-16 15:39:59, 769-0500 FATAL pdflatex - The operation could not be completed because the following package is unknown:unicode-data
  • 2016-12-16 15:39:59, 769-0500 FATAL pdflatex - Info: 2016-12-16 15:39:59, 769-0500 FATAL pdflatex - Source:
    Libraries\MiKTeX\PackageManager\PackageInstaller.cpp
  • 2016-12-16 15:39:59, 769-0500 FATAL pdflatex - Line: 3291|

I tried to install the package unicode-data from the CTAN site, this didn't solve the problem.

Any help or suggestions would be very much welcome.


RESOLVED: The problem was that the package was just not in my local package repository (never happened before). In fact, the package was not listed in the MiKTeX Package Manager, so I had installed it manually, which didn't help (I might not have installed it properly after all) after "Changing Package Repository" in MiKTeX Package Manager to the internet based repository, the package did appear in the listing and installing it solved the problem.

  • 1
    Try to install (preferably as Admin) from MiKTeX Package Manager, while compilation has ceased. – Bernard Dec 16 '16 at 21:24
  • For some reason (which might be very much related to the error) I can not find unicode-data package in MiXTeX package manager (there is, however, package called unicode-math). The package does appear in the link ftp.math.purdue.edu/mirrors/ctan.org/systems/win32/miktex/tm/…, so I have installed it manually, is there a way to point MiXTeX Pkg. Manager to this link? – them Dec 16 '16 at 21:30
  • I have it. Synchronize the contents of the repositories (menu Repository -> Synchronize in MPM 'Admin), then install. – Bernard Dec 16 '16 at 22:21
  • @them could you answer your own question and mark it as solved? – Jan Dec 17 '16 at 8:19
  • @Jan answered it. – them Dec 17 '16 at 18:21
1

I am writing how I have resolved my issue as a separate answer.

The package was not in my local package repository, after "Changing Package Repository" in MiKTeX Package Manager to the internet based repository, the package did appear in the listing and installing through MiKTeX Package Manager solved the problem.


Some details: MiKTeX Package Manager was configured to use a local repository on my PC, which I downloaded with the installation of TeXstudio, the unicode-data package was not in my local package repository, this never happened before with any other package, and the error didn't clearly reflect what was the problem.

All I have seen is that the package was not listed in the MiKTeX Package Manager, so I had tried to installed it manually, there seemed to be no issues with the manual installation, but apparently the installation didn't go through. After "Changing Package Repository" in MiKTeX Package Manager to the internet based repository, the package did appear in the listing and installing it solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.