1

I tried to install TeXlive on my laptop running Windows 10.

Installing [3110/3342, time/total: 01:23:03/01:29:44]: udesoftec [618k] 
Installing [3111/3342, time/total: 01:23:05/01:29:45]: uebungsblatt [226k]
Installing [3112/3342, time/total: 01:23:06/01:29:45]: uestcthesis [4168k]
Installing [3113/3342, time/total: 01:23:10/01:29:39]: uhc [3517k]
untar: untarring C:\Users\xxx\AppData\Local\Temp\mTonFCCsKX\3U9pWgDmDk\uhc.tar failed (in C:\texlive\2016\texmf-dist)

TLPDB::_install_package: untar failed
Installation failed.
Rerunning the installer will try to restart the installation.
Or you can restart by running the installer with:
  install-tl-windows.bat --profile installation.profile [EXTRA-ARGS]
or
  install-tl-advanced.bat --profile installation.profile [EXTRA-ARGS]

Please give a hand and a solution on it. Thanks!

1

I was struggling with similar problems and got it working now. What I have done differently now:

  • Store installer on same hard drive partition as the installation.
  • Run install-tl-advanced.bat instead of install-tl-windows.bat.

Hope this helps anybody else.

1

Be sure to check your environment variables for other tar.exe files, I had one from mingw that caused the problem. Removing the mingw bin folder (temporary) from the path solved the problem.

  • Well, can you add an screenshot of what you mean? What is mingw that it couses such an issue? Please explain better why that is a solution (we do not know the OP uses mingw too ...) BTW: Welcome to TeX.SE! – Mensch Jul 13 '19 at 14:53
  • Good hint for me. Seems like the installer is takeing the first tar executable it can find (in my case the one from mingw which was available based on the PATH variable of my system environment) without making sure it is a compatible one. – Matthias Jul 30 '19 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.