3

I have had TeXLive 2016 installed on my machine for some time. Today, I issued the command tlmgr update --self --all and, for some reason, tlmgr auto-installed cslatex, which generated an error message, I think due to missing hyphenation packages:

 [8/9, 00:11/00:11] auto-install: cslatex.x86_64-darwin (18441) [1k] ... done
 [9/9, 00:11/00:11] auto-install: cslatex (40855) [36k] ... done
 tlmgr: package log updated: $PATH_TO_TEXLIVE/texmf-var/web2c/tlmgr.log
 running mktexlsr ...
 done running mktexlsr.
 running updmap-sys ...
 done running updmap-sys.
 regenerating fmtutil.cnf in $PATH_TO_TEXLIVE/texmf-dist
 running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --no-error-if-no-format --byengine tex ...
 done running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --no-error-if-no-format --byengine tex.
 running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt dvilualatex ...
 done running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt dvilualatex.
 running fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt cslatex ...

 tlmgr: fmtutil-sys --no-error-if-no-engine=luajittex,mfluajit --byfmt cslatex failed (status 1), output:
 fmtutil: fmtutil is using the following fmtutil.cnf files (in precedence order):
 fmtutil:   $PATH_TO_TEXLIVE/texmf-dist/web2c/fmtutil.cnf
 fmtutil: fmtutil is using the following fmtutil.cnf file for writing changes:
 fmtutil:   $PATH_TO_TEXLIVE/texmf-config/web2c/fmtutil.cnf
 fmtutil [INFO]: writing formats under $PATH_TO_TEXLIVE/texmf-var/web2c
 fmtutil [INFO]: --- remaking cslatex with pdftex
 fmtutil: running `pdftex -ini   -jobname=cslatex -progname=cslatex -etex cslatex.ini' ...
 This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016) (INITEX)
  restricted \write18 enabled.
 entering extended mode

 ($PATH_TO_TEXLIVE/texmf-dist/tex/cslatex/base/cslatex.ini jobname=cslatex with pdftex, DVI output initialised.
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/latex.ltx
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/texsys.cfg)
 ./texsys.aux found


 \@currdir set to: ./.


 Assuming \openin and \input 
 have the same search path.


 Defining UNIX/DOS style filename parser.

 catcodes, registers, compatibility for TeX 2,  parameters,
 ***** WARNING ******** CSLaTeX is obsolete, don't use it please *****
 ***** You can use ``normal'' LaTeX+Babel or XeLaTeX+polyglossia *****
 LaTeX2e <2016/03/31> patch level 3
 LaTeX2e <2016/03/31> patch level 3
 hacks, control, par, spacing, files, font encodings, lengths,
 ====================================

 Local config file fonttext.cfg used

 ====================================

 ($PATH_TO_TEXLIVE/texmf-dist/tex/cslatex/base/fonttext.cfg
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/omlenc.def)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/t1enc.def)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/ot1enc.def)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/cslatex/base/il2enc.def)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/omsenc.def)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/t1cmr.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/ot1cmr.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/cslatex/base/il2cmr.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/ot1cmss.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/ot1cmtt.fd))
 ====================================

 Local config file fontmath.cfg used

 ====================================

 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/fontmath.cfg
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/fontmath.ltx
 === Don't modify this file, use a .cfg file instead ===


 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/omlcmm.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/omscmsy.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/omxcmex.fd)
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/ucmr.fd)))
 ====================================

 Local config file preload.cfg used

 =====================================

 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/preload.cfg
 ($PATH_TO_TEXLIVE/texmf-dist/tex/latex/base/preload.ltx)) page nos., x-ref, environments, center, verbatim,
 math definitions, boxes, title, sectioning, contents, floats, footnotes,
 index, bibliography, output,
 ===========================================
 Local configuration file hyphen.cfg used
 ===========================================

 ($PATH_TO_TEXLIVE/texmf-dist/tex/cslatex/base/hyphen.cfg 
 Loading english hyphenation patterns and exceptions
 ($PATH_TO_TEXLIVE/texmf-dist/tex/generic/hyphen/hyphen.tex)
 ! OOPS!! Hyphenation patterns file czhyphen.tex for czech not found!.
 \reserved@a ...@gobble \string \czech  not found!}

 l.131 ...                        \@requesthyphens}
                                                   %
 ? 
 ! Emergency stop.
 \reserved@a ...@gobble \string \czech  not found!}

 l.131 ...                        \@requesthyphens}
                                                   %
 No pages of output.
 Transcript written on cslatex.log.
 fmtutil [ERROR]: running `pdftex -ini   -jobname=cslatex -progname=cslatex -etex cslatex.ini </dev/null' return status 1
 fmtutil [ERROR]: return error due to options --strict
 fmtutil [INFO]: Disabled formats: 1
 fmtutil [INFO]: Not selected formats: 14
 fmtutil [INFO]: Failed to build: 1 (pdftex/cslatex)
 fmtutil [INFO]: Total formats: 16
 fmtutil [INFO]: exiting with status 1

It then tries to generate several other Czech formats, with the same error. Indeed, csplain, which tlmgr show czhyphen says is the lone distribution containing the file czhyphen.tex, is not installed. I guess that I could install it, but why do I need to do so? I don't want to write in Czech, and the author of CSLaTeX says:

Cslatex package is considered obsolete. Users should use instead it the ``normal'' LaTeX with a package which provides a multilingual support.

(source). Is this a bug (either installing it at all, or, if it really must be installed—tlmgr thinks it must:

$ tlmgr remove cslatex
tlmgr: not removing cslatex.x86_64-darwin, needed by cslatex
tlmgr: not removing cslatex, needed by latex-bin
tlmgr: no packages removed.
tlmgr: action remove returned an error; continuing.
tlmgr: An error has occurred. See above messages. Exiting.

—accidentally not bundling the czhyphen.tex file)? What should I do?

EDIT: Somehow, despite the error, tlmgr believed that cslatex actually did install; so, though I am worried about the state of my system, it seems to be running OK.

EDIT 2 (at the same time, since I ran tlmgr update --self --all again just now): It seems to have been fixed; cslatex was auto-removed.

  • 2
    tl bugs should be sent to mailing list as listed here: tug.org/texlive/bugs.html I just did a full update with no error but perhaps it depends on the state that you are updating from. – David Carlisle Dec 19 '16 at 20:28
  • @DavidCarlisle, thanks for the pointer. I wasn't sure if this was a bug, and it seemed like TeXLive questions were OK here. Do you have csplain and/or cslatex installed? – LSpice Dec 19 '16 at 20:36
  • 2
    It's Ok to post here as far as this site is concerned but unless someone forwards to the list chances are no one who can fix it will see:-) I have both cs formats already installed so i guess that's the difference – David Carlisle Dec 19 '16 at 21:01
  • 1
    @DavidCarlisle Any idea how to solve it? – Keks Dose Dec 21 '16 at 16:47
  • 1
    @KeksDose no but it's been raised on tl list – David Carlisle Dec 21 '16 at 23:16
1

To avoid another question without an answer:

The issue has been solved. An update of texlive included the removal of the package cslatex and cslatex.x86_64-linux and probably as well the removal of any other cslatex.*-bin for other platforms. fmutil (or fmutil-sys) runs without error.

  • Do you happen to have a link to a discussion of this? In some sense, the fact that it's fixed is all that matters, but I'd love to know what happened. – LSpice Dec 22 '16 at 19:09
  • @LSpice Sorry, no link. – Keks Dose Dec 23 '16 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.