23

When I usually open a PDF with Acrobat Reader it opens it in Fill Window mode (the page fills all the space of the window). When using the hyperref package it always opens the file in Full page mode (show a single page at a time and jumps from page to page when scrolling) and show the bookmarks.

How to make this effect disappear? I know there is an option of hyperref that forces the way a PDF file is opened but I forgot and are having trouble finding it again.

Thanks if you remember it or can find it easily and tell us.

2
  • For example. I found that there is \hypersetup{pdfpagemode=...} and you can put options in the ... like "UseNone, UseThumbs (show thumbnails), UseOutlines (show bookmarks), FullScreen, UseOC (PDF 1.5), and UseAttachments (PDF 1.6). If no mode if explicitly chosen, but the bookmarks option is set, UseOutlines is used. " Commented Sep 24, 2010 at 15:53
  • 1
    Related Question: How to set LaTeX so that PDF reader opens PDF file in a prespecified view?. Commented Mar 17, 2013 at 21:53

2 Answers 2

25

You can use the \hypersetup command of the hyperref package. See the package documentation (bottom of page 18).

To solve your problem you can try:

\hypersetup{pdfstartview={XYZ null null 1.00}}

It instructs the PDF reader to use initial view zoom factor = 1.00, i.e., to open at zoom = 100%. Other pdfstartview= values include Fit, to show the whole page; FitH, to fit the width of the page in the window; or FitB, to fit the width of the contents to the window.

2
  • 1
    That's the one! and with the FitH option is what I needed. Thanks. Commented Sep 24, 2010 at 15:57
  • 1
    Actually, I think one can nowadays just do pdfstartview= to leave the entry out of the dictionary entirely, so that the PDF viewer just does whatever it normally does.
    – SamB
    Commented Dec 16, 2010 at 23:36
24

Geoffrey is close, but not quite correct. To really make hyperref stop overriding Adobe [Acrobat] Reader's default zoom settings, you need to pass this setting to hyperref:

\hypersetup{pdfstartview=}

This causes hyperref to omit the relevant key from the relevant PDF dictionary entirely, so that Reader just uses the (user-configured) default, even if the user has chosen something different from FitH.

(Note that support for an empty value for this option was added more recently than the option itself, so it is unfortunately not possible to get all versions of hyperref to leave this key out of the PDF.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .