7

Update of my MikTeX portable on Win 7 failed this morning (Dec 24th, 2016). The error message is given below. Prior to that a lot of packages have been removed, obviously some critical ones among them as well. My offline DB was syncronized. Was my update too early or what might be the cause?enter image description here

3
  • When did you the update before this one? Dec 24 '16 at 11:17
  • Try uninstalling MiKTeX and then reinstalling it.
    – user79095
    Dec 24 '16 at 13:52
  • It looks as if you can't start the update manager GUI. Try to call it from the command line in the trash-menu of miktex portable. See also my comment here sourceforge.net/p/miktex/bugs/2546/#7751 (don't use the --repository-release-state=next option). Dec 24 '16 at 13:58
10

Analyzing mpm logs and miktex sources gives a hint that MiKTeX Update Manager incorrectly handles a situation when no proxy is set. So I entered the proxy (Connections Settings... button) (I used uk11.frigate.org), after which the update process worked.

5
  • I just should add that this procedure worked for me with both a 32-bit portable and 64-bit stationary installation.
    – stu003
    Dec 24 '16 at 23:48
  • 3
    Once this has been done, you don't need the proxy settings anymore and it seems to fix itself after the one update of doom. Jan 1 '17 at 17:19
  • 1
    This worked for me, too. And the proxy settings can be removed after that. Thanks.
    – Arzigoglu
    Jan 4 '17 at 8:48
  • I am facing the same problem but could not fix it. Can you please provide some pictorial suggestions? I don't know how to enter proxy settings
    – Manjoy Das
    Apr 27 at 2:11
  • In the connection setting button, there is no box to put URL.
    – Manjoy Das
    Apr 27 at 2:31
6

I had a similar problem this morning (1st: update of the system -> went fine; then update of the packages with error as above) and tried answer 2 (proxy setting). As I have no proxy, I just checked and unchecked the box. Then tried "let me choose repository" and manually selected one. After this the update worked.

P.S. There was an error messages at the end "executed process did not succed", but there seem to be no furtehr update.

Update: There seems to be a problem with the "nearest site selection" Maintainance "Update formats" needed to load multiple packages, which also only worked after manually selecting repository.

1
  • 2
    I can confirm that this worked for me. I was getting the same error as reported by the OP after the second update, and the fix was to click "Connection Settings" and then tick the box "Use a proxy server" and then immediately untick it again. Afterwards, I was able to proceed through the wizard as usual. Jan 3 '17 at 0:53
1

The same has happened to me today. I fixed the issue doing the following steps:

  1. Uninstall MiKTeX completely (after uninstalling from the Control Panel, I had to manually delete the folder in Program Files, for some reason).
  2. Install using the basic installer.
  3. Run MiKTeX Update.
  4. Run MiKTeX Update (once again, yes, first time it will allow you to install just some basic updates).
  5. Compile the document.

This is what has worked for me so far. I have left the on-the-fly package install as "ask me first".

Note: After step 2 I tried compiling directly, but after installing the required packages I got incompatibilities between biber and biblatex.

1

I had the same problem on one of my machines. Running the update from a DOS prompt worked. After that, I tried checking and unchecking the proxy box as suggested in one of the earlier answers. After that, the update wizard works again.

1

Updating an old MiKTeX installation or installing the current basic-miktex-2.9.6161 and updating it leads to the described error. (Such things should never happen, but it is not the first time.) The suggested deinstall + reinstall does not help.

The combination of packages in the 2016-12-23 repos seems to be broken (at least for some systems). I suggest: Do not update and wait for another release.

As of 2017-01-05, MiKTeX.org writes:

MiKTeX Update Wizard issues

Last edited: 1/5/2017 10:06:29 AM

The latest Version of the update wizard has issues on some Windows Systems. The problem has been identified and a fix is available here:

https://ctan.org/tex-archive/systems/win32/miktex/support/update

Update

A few days later, the next version of MikTeX worked again.

1

I was also experiencing the update - the reason was I had a document opened and a compilation in progress:-D simply stop it and close the MikTeX then check for updates from any random source.

1
  • Note this is not a fix for the original error message (shown in question) i.e. a connection error MiKTeX will tell you off by means of a very explanatory error message for trying to update open files.
    – user170109
    Jan 9 '19 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.