3

I tried an update of my miktex2.9 on win 7, but started getting "Couldn't resolve host name" from MiKTeX Package Manager each time I tried installing a new package . Can I seek your advice on how I should overcome this? Thank you in advanced.

Here is the log error when I try to instal new package :

MiKTeX Problem Report
Message: Couldn't resolve host name
Data: 
Source: Libraries\MiKTeX\PackageManager\CurlWebSession.cpp
Line: 329
MiKTeX: 2.9
OS: Windows 7 Ultimate, 64-bit, Service Pack 1, build 7601
Invokers: explorer
SystemAdmin: yes
PowerUser: no
Root0: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\sanae\AppData\Local\MiKTeX\2.9
Root2: C:\ProgramData\MiKTeX\2.9
Root3: C:\Program Files\MiKTeX 2.9
UserInstall: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\sanae\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9

Here is the log error when I try to update Wizard :

MiKTeX Problem Report
Message: MiKTeX encountered an internal error.
Data: 
Source: Programs\MiKTeX\PackageManager\MFC\MpmView.cpp
Line: 918
MiKTeX: 2.9
OS: Windows 7 Ultimate, 64-bit, Service Pack 1, build 7601
Invokers: explorer
SystemAdmin: yes
PowerUser: no
Root0: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\sanae\AppData\Local\MiKTeX\2.9
Root2: C:\ProgramData\MiKTeX\2.9
Root3: C:\Program Files\MiKTeX 2.9
UserInstall: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\sanae\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\sanae\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9

Any ideas how to fix this ?

closed as off-topic by TeXnician, Sebastiano, Stefan Pinnow, Marcel Krüger, Bobyandbob Aug 13 '18 at 9:08

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Just in case: are you sure the compiler wasn't running (e.g. waiting for some answer on the console) when you launched MPM or MiKTeX Update? – Bernard Dec 25 '16 at 19:50
  • Yes i m sure nothing was running in my computer – Nousa Dec 25 '16 at 19:54
  • Maybe try to change repository from MPM and synchronise. – Bernard Dec 25 '16 at 19:56
  • it doesn't work, I still get the same error messages – Nousa Dec 25 '16 at 20:07
  • 4
    I'm voting to close this question because the OP solved it by reinstalling (see comments). – TeXnician Aug 13 '18 at 7:44
0

Open the MikTex Package Manager and check the Repository configuration.

If you want to install from the Internet and are behind a proxy firewall, you will need to set the proxy server information. Choose the desired mirror to download packages from. If the mirror site is unavailable when you try to use it you may get an error and will need to change the repository location.

  • Can you elaborate on "set the proxy server information"? – littleO Jul 10 '17 at 21:30
  • I would like to know what that means too. – Colin McLarty Dec 2 '17 at 23:24
0

You have to give your proxy settings in the connectivity if you are choosing to install the packages from internet. After setting the proxy you need to give your proxy authentication.

  • Welcome to TeX.SX! While this may answer similar questions it does not answer the question in the OP (see comments). Furthermore it duplicates the other answer. – TeXnician Aug 13 '18 at 7:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.