7

The title of a work I have to cite has a word ending with an apostrophe. Given this post, I'm using the ASCII single quote (') to write the entry, but this generates the following problem:

citation with word ending in apostrophe, stuck to next word

As you can see, the words "managers'" and "prior" are stuck. I checked how this article is cited on Google Scholars. To my surprise, they use the Unicode "right single quotation mark" (). I used it in my .bib file and it worked!

citation with word ending in apostrophe, no longer stuck to next word

Why does this happen?

Thanks in advance.

@article{sandor01_conjoint,
title   = "Designing conjoint choice experiments using managers' prior beliefs",
author  = "Zsolt Sándor and Michel Wedel",
year    = "2001",
journal = "Journal of Marketing Research",
volume  = "38",
number  = "4",
pages   = "430--444"
}

@article{sandor01_conjoint,
title   = "Designing conjoint choice experiments using managers’ prior beliefs",
author  = "Zsolt Sándor and Michel Wedel",
year    = "2001",
journal = "Journal of Marketing Research",
volume  = "38",
number  = "4",
pages   = "430--444"
}

Edit: I add a MWE. The packages that fix the language to spanish are mandaroty, because the references have to be in spanish (e.g. Name Surname y Name Surname instead of Name Surname and Name Surname).

\documentclass[letterpaper, 12pt, oneside]{book}

\usepackage[activeacute,spanish]{babel}
\usepackage[utf8]{inputenc}

\usepackage[fixlanguage]{babelbib}
\selectbiblanguage{spanish}

\begin{document}

Hello world \cite{sandor01_conjoint}

\bibliographystyle{babalpha-fl}
\bibliography{bibliografia}

\end{document}
  • 3
    Can you please add a minimal example of LaTeX code? – egreg Dec 26 '16 at 15:20
  • 1
    Please add a minimal working example (MWE) that illustrates your problem. Currently nobody can reproduce your output without a lot of effort. – Henri Menke Dec 26 '16 at 15:20
6

Remove the activeacute option: if you use UTF-8 you don't need it.

\begin{filecontents*}{\jobname.bib}
@article{test1,
title   = "Designing conjoint choice experiments using managers' prior beliefs",
author  = "Zsolt Sándor and Michel Wedel",
year    = "2001",
journal = "Journal of Marketing Research",
volume  = "38",
number  = "4",
pages   = "430--444"
}

@article{test2,
title   = "Designing conjoint choice experiments using managers’ prior beliefs",
author  = "Zsolt Sándor and Michel Wedel",
year    = "2001",
journal = "Journal of Marketing Research",
volume  = "38",
number  = "4",
pages   = "430--444"
}
\end{filecontents*}

\documentclass[letterpaper, 12pt, oneside]{book}

\usepackage[spanish]{babel}
\usepackage[utf8]{inputenc}

\usepackage[fixlanguage]{babelbib}
\selectbiblanguage{spanish}

\begin{document}

Hello world \cite{test1} and \cite{test2}

\bibliographystyle{babalpha-fl}
\bibliography{\jobname}

\end{document}

The filecontents* environment is used just to make the example self-contained and not clobber my files.

enter image description here

If you really need activeacute, type in the apostrophe as

Designing conjoint choice experiments using managers'{} prior beliefs
  • Whoa! I never thought activeacute could cause this issue. As I understand, the option allows me to write accents using the \'a format to obtain á. Now that I think about it, given that I use \usepackage[utf8]{inputenc}, activeacute is no longer necessary. – Ignacio Correa Dec 26 '16 at 17:47
  • @IgnacioCorrea The option allows you to type 'a (without backslash) to get á. You can still type \'a without the option, if you prefer. – egreg Dec 26 '16 at 17:50
  • You're right, but as a native spanish speaker, it is much more comfortable to type á right away than 'a or \'a, because of grammar checks and the like. Thank you for your answer and comment! – Ignacio Correa Dec 27 '16 at 17:43
2

Various things like managers{'} prior did not work, but managers'\ prior did work.

\documentclass[letterpaper, 12pt, oneside]{book}

\usepackage[activeacute,spanish]{babel}
\usepackage[utf8]{inputenc}

\usepackage[fixlanguage]{babelbib}
\selectbiblanguage{spanish}
\usepackage{filecontents}
\begin{filecontents*}{bibliografia.bib}
@article{sandor01_conjoint,
title   = "Designing conjoint choice experiments using managers'\ prior beliefs",
author  = "Zsolt Sándor and Michel Wedel",
year    = "2001",
journal = "Journal of Marketing Research",
volume  = "38",
number  = "4",
pages   = "430--444"
}
\end{filecontents*}

\begin{document}

Hello world \cite{sandor01_conjoint}

\bibliographystyle{babalpha-fl}
\bibliography{bibliografia}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.