7

I want to use initials in authoryear style instead of full given names. I tried:

\usepackage[backend=biber,style=authoryear,hyperref=true,giveninits]{biblatex}

It works properly but produces the warning:

Conflicting options.

How to properly customize authoryear style then?

11

The full warning message I get in the .log is

Package biblatex Warning: Conflicting options.
(biblatex)                '<namepart>inits' conflicts with 'uniquename=full'.
(biblatex)                Setting 'uniquename=init' on input line 10.

This tells you that since you only want given/first name initials with the option giveninits, you can't get full uniquename disambiguation if need be (as automatically requested by the authoryear style with uniquename=full). The message goes on to say that the option will be set to

uniquename=init

to allow for name disambiguation at least by name initials.

If you don't want the warning in the first place, just load biblatex with uniquename=init from the start.

\usepackage[backend=biber,style=authoryear,uniquename=init,giveninits]{biblatex}

If you don't want name disambiguation at all, use uniquename=false instead (see biblatex, authoryear style: In-text citations display first name initials for certain bibliography entries for example).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.