5

This should probably be a bug report and not a question, however I am not sure where to put it (LuaLaTeX? crop package? microtype package?) and so I hope it shall find its way to those who can do something about it if I just describe the problem here.

The problem appears when I try to use both crop (and geometry for support) package(s) and microtype package (both current versions from TeXLive 2016 with all updates up today), and appears only when run with LuaLaTeX v. 0.95.0 from TeXLive 2016 (with older LuaLaTeX 0.80.0 from TeXLive 2015 there is no problem).

MWE:

%%%! LuaLaTeX

\documentclass[a4paper]{article}
\usepackage{microtype}
\usepackage[dvips=false,pdftex=false,vtex=false,
            paperwidth=150mm,paperheight=215mm,noheadfoot]{geometry}
\usepackage[a4,center]{crop}
\crop[cam,axes,noinfo]

\begin{document}
Hi!
\end{document}

When compiled an error appears:

! Undefined control sequence.
\CROP@init@pdftex ...h \stockwidth \pdfpageheight 
                                                  \stockheight \let \CROP@re...
l.10 \begin{document}

?

If I ignore the error (enter the 'r' command to go into \nonstopmode) the rest of the compilation finishes OK and crop works.

If I comment out either the microtype package or crop package and command, compilation runs OK.

  • add the package luatex85. – Ulrike Fischer Dec 27 '16 at 18:05
  • @Ulrike: Thank you Ulrike, this works. I just hope it doesn't have any side effects. – Marcel S. Dec 27 '16 at 18:33
5

As Ulrike's comment suggests and luatex85 documentation explains, the problem is caused by changes in LuaTeX versions 0.85+, namely removing or renaming some pdfTeX extended primitives.

So the solution is to add

\RequirePackage{luatex85}

at the beginning of the compiled file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.