0

I am a complete beginner in terms of vectorial graphics. In my Bachelor Thesis I get data (provided in the attached file), which I want to compile with the programm Asymptote. I know, that it is possible to configure my TexStudio in a way, that it compiles .asy files. But my supervisor don't want me to do it like that. I already downloaded the programm Asymptote and got the file. However I am not able to compile it under Windows 10. I think im just doing a stupid mistake in terms of syntax, because my Supervisor can compile the provided file under Ubuntu with Asymptote.

Now my question: Can someone give me a detailed "command" path to how I can compile the file?

I already tried the following:

  1. start Asymptote
  2. change the directory to the folder where "plots.asy" is
  3. file fin=input("plots.asy") and then I get an error 1.1 "Cannot open file "plots.asy".

So I also already tried to use my Windows shell and compile it with this in the following way:

  1. Start the Windows shell
  2. change the directory to the folder with "plots.asy"
  3. type: asy.exe -f .png "plots.asy" and run it. then I get the following error:

    plots.asy: 1.13: cannot call 'guide operator --(... guide[])' with parameters '(triple, triple)' plots.asy: 1.49: no matching variable 'Arrow3'

I already tried to solve my problem by reading the manual provided by Asymptote itself, but i just can't figure it out. I already searched this forum and some other tutorials, but I only found either the manual or the problem is not the same as mine.

And last but not least the file. It's uploaded on fileupload.net, I hope this is ok.

1

Put

import three;

before the first line of the file.

  • Ok, with this i get it to load with the windows shell way, however i get an "out of memory" error then. I looked it up and my task manager shows, that not even 20% of my RAM is used. Everything else is also normal. Any idea why this happens? – Killuah13 Dec 29 '16 at 22:34
  • On my MacOS system your file with that line added compiles without problems. But it seems that "out of memory happens more on Windows. Google "asymptote out of memory". – Pieter van Oostrum Dec 29 '16 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.