42

I have downloaded the new ACM template for conference proceedings (sigconf format). Even when I comment out the lines that are related to conference information, price, DOI, etc. I get the following lines on the first page:

Conference’17, Washington, DC, USA
2016. 978-x-xxxx-xxxx-x/YY/MM. . . $15.00
DOI: 10.1145/nnnnnnn.nnnnnnn

I have uncommented the line

\setcopyright{none}

so the copyright notice is gone, but the above information is still there (from acmart.cls)

Additionally, I get the paper's name on odd pages and conference information at the top of every page. How should I remove these lines?

  • 4
    Try the nonacm option. <acm.org/binaries/content/assets/publications/…> – Ben Greenman Apr 11 at 19:04
  • 1
    Second the nonacm option, which uses the same typesetting but without the header, footer and the permission block. As stated in the documentation "Use the class typeseing options for a non-ACM document, which will not include the conference/journal header and footers or permission statements". – qweruiop May 20 at 16:37
67

Add the following lines below the \documentclass line.

\settopmatter{printacmref=false} % Removes citation information below abstract
\renewcommand\footnotetextcopyrightpermission[1]{} % removes footnote with conference information in first column
\pagestyle{plain} % removes running headers

Removing "Manuscript submitted to ACM": add \fancyfoot{} in the preamble and \thispagestyle{empty} after \maketitle

Removing DOI information only: Using the command \acmDOI{} to set the DOI to an empty string has only a limited effect: In the ACM reference format and in the copyright notice the prefix https://doi.org/ still remains. Only when using the class option authorversion, this prefix will vanish in the footnote, but will still be part of the ACM reference. (Imho this is a bug.) Here is a hack to get rid of this prefix (and of any DOI that has been set).

Add the lines

\makeatletter
\renewcommand\@formatdoi[1]{\ignorespaces}
\makeatother

after the \documentclass line. This will remove the DOI line in the ACM reference format completely (including the line break). The conference information in the footnote will still retain the line break, which leads to a small extra vertical space. To avoid this, suppress the complete copyright notice by \renewcommand\footnotetextcopyrightpermission[1]{} (see above), or redefine \footnotetextcopyrightpermission in a more sophisticated way by just removing the \@formatdoi command with the preceding \\ from the original definition (see the class file).

  • Do you now how to remove just the doi line? – Derzu Jul 12 '17 at 19:21
  • 1
    @Derzu See my updated answer. – gernot says Reinstate Monica Jul 13 '17 at 7:12
  • FWIW: bugs can be reported to github.com/borisveytsman/acmart and the author is usually very responsive (especially for things that don't affect camera-ready output, hence don't need ACM approval). For this issue there's a recent pull request with changes to the class file: github.com/borisveytsman/acmart/pull/185 – Blaisorblade Jul 26 '17 at 21:25
  • 1
    Unfortunately, I added the first line after documentclass and all the information still appears, but only on the first page. – 6005 Jul 3 '18 at 4:00
  • @6005 I've just tested the commands with the recent version of sample-sigconf.tex, and the lines have exactly the effect as specified in the comments. The first line, \settopmatter{printacmref=false} removes the citation information that appears below the abstract, as expected. Clearly, this information is on the first page (or on the second, at the latest). What else do you expect? – gernot says Reinstate Monica Jul 3 '18 at 12:48

protected by Community Apr 8 '18 at 7:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.