0

This question already has an answer here:

The following are related tutorial and articles:

  1. Embedding videos and animations
  2. https://www.youtube.com/watch?v=yJPyl9AKhmE

I want to insert a movie in my slide with the following codes:

\documentclass{beamer}
\mode<presentation>
{
  \usetheme{default}      
  \usecolortheme{default} 
  \usefonttheme{default} 
  \setbeamertemplate{navigation symbols}{}
  \setbeamertemplate{caption}[numbered]
} 
\setbeamertemplate{frametitle}[default][center]
\usepackage[english]{babel}
\usepackage[3D]{movie15}
\usepackage[utf8x]{inputenc}




\begin{document}
\begin{frame}{Movie}
\begin{columns}
\begin{column}{4.2cm}
\begin{block}{A}
\includemovie[autoplay,repeat]%
{4cm}{3cm}{goose.mp4}
\end{block}
\end{column}
\end{columns}
\end{frame}
\end{document}

I put the video in the same file of the this latex document.
My video file is: MP4 Video (.mp4)

However, it only shows the following:

enter image description here

Well, I can open this video; however, I cannot open it in my pdf file.
How to fix it?

marked as duplicate by user36296 beamer Mar 12 '17 at 13:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    1st This looks more than a Foxit Reader problem rather than a LaTeX problem. 2nd Have you tried Adobe Reader? – Dr. Manuel Kuehner Jan 1 '17 at 2:35
  • @Dr.ManuelKuehner Yes, however it cannot work either. My question then should be is my code correct? I mean does it work in your or others' computer? I have only one computer. – sleeve chen Jan 1 '17 at 2:37
  • See tex.stackexchange.com/a/321572/36296 how to configure foxit. "[...] you may need to mark the document file/folder as trusted in Preferences > Security and make sure that javascript is enabled in Preferences > Trust Manager." – user36296 Jan 1 '17 at 12:33
  • It should work with media9, see tex.stackexchange.com/a/345433/36296 – user36296 Jan 1 '17 at 12:37