1

I'd like the make the contents and the acknowledgements appear in the table of contents just like the picture below. Can you tell me how ?

Thanks a lot

enter image description here

Here is my MWE:

\documentclass[12pt,twoside]{report}
\usepackage[a4paper,width=150mm,top=25mm,bottom=25mm]{geometry}
\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhf{}
\fancyhead[RE]{\slshape\nouppercase{\leftmark}}
\fancyhead[LO]{\slshape\nouppercase{\rightmark}}
\fancyhead[RO,LE]{\thepage}
\renewcommand{\headrulewidth}{0pt}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{lipsum}
\graphicspath{{Images/}}
\begin{document}
\pagestyle{headings}
\chapter*{Acknowledgements}
\thispagestyle{empty}
\pagenumbering{arabic}
\tableofcontents
\addcontentsline{toc}{chapter}{\listfigurename}\addcontentsline{toc}{chapter}{\listtablename}
\pagenumbering{roman}
\listoffigures
\listoftables
\clearpage
\pagenumbering{arabic}
\chapter{Introduction}
Some text
\end{document}
  • 2
    Please, add your MWE. – Sebastiano Jan 2 '17 at 17:32
  • \pagenumbering resets the page counter, so you have two pages numbered arabic one (acknowledgements, introduction) and one page numbered roman one (Contents). Probably the easiest way to fix it is to use the book class with \frontmatter and \mainmatter, see e.g. tex.stackexchange.com/questions/154646/… – gernot says Reinstate Monica Jan 2 '17 at 17:57
1

For the table of contents, use the lines

\cleardoublepage
\addcontentsline{toc}{section}{\numberline{}Contents}
\tableofcontents

If your document class starts chapters on the next page (like article and report classes) instead on the next odd page (like book classes or report classes with the twoside option), replace \cleardoublepage by \clearpage.

For the acknowledgements, use

\chapter*{Remerciements (Acknowledgements)}
\addcontentsline{toc}{section}{\numberline{}Remerciements (Acknowledgements)}
  • Thank you this worked fine but those entries are indented in the table of contents. Is there a way to intend them a bit less ? – Alexandre Bohyn Jan 2 '17 at 17:47
  • In your example document the entries are also indented, aligned with the section entries. This is why they are also indented in my answer. If you want to have them flush left, remove \numberline{}. – gernot says Reinstate Monica Jan 2 '17 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.