2

I use a quite complicated way to make my citation, as I need to use the same citation as a reference in different places in my text.

Now I got the correct way of showing the citation in footnote, but each citation has 2 numbers, and the number of the citation is not in order (the one with squared brackets). It comes out like

1[3], 2[1], 3[4], 4[2] 

I want them show as (this problem has been solved with sorting=none)

[1],[2],[3],[4]

And how to remove the number 1 before [1]? Is that possible to set the referenced citation also as superscript inside the text? In order to keep reference citation work, I keep the script for footpartcite and partcite.

Thank you!

\documentclass[a4paper, 12pt, headsepline,DIV=12,twoside]{report}
\usepackage[english]{babel}
\usepackage{mathptmx} 
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{parskip}
\usepackage{filecontents}
\usepackage[backend=bibtex,style=numeric,natbib=true]{biblatex}
\usepackage{textcomp}
\usepackage{csquotes}

\begin{filecontents}{\jobname.bib}
@Electronic{unintentional,
Title                    = {Accidents or Unintentional Injuries},
Author                   = {{National Center for Health Statistics}},
URL                      = {http://www.cdc.gov/nchs/fastats/accidental-  injury.htm},
urldate                  = {2016-08-10},}
@Book{HP,
Title                    = {Harry Potter and the Philosopher's Stone},
Author                   = {{Rowling,J. K. }},
Date                     = {1997}}
@Misc{ASH,
Title                    = {Automotive Safety Handbook},
Author                   = {{Seiffert, Ulrich; Wech, Lothar}},
Date                     = {2003},
Editor                   = {SAE International},
Note                     = {pp. 91, 96, 97}}
@Electronic{CrashStatistic,
Title                    = {Annual Global Road Crash Statistics},
Author                   = {{Association for Safe International Road Travel}},
Date                     = {2016-07-16},
Url                      = {https://asirt.org/initiatives/informing-road-users/road-safety-facts/road-crash-statistics}}
\end{filecontents}

\usepackage{xcolor} 
\usepackage{hyperref}
\hypersetup{colorlinks,linkcolor={black},citecolor={blue!50!black}}

\DeclareCiteCommand{\footpartcite}[\mkbibfootnote]
{\usebibmacro{prenote}}
{\usebibmacro{citeindex}%
\mkbibbrackets{\usebibmacro{cite}}%
\setunit{\addnbspace}
\printnames{labelname}%
\setunit{\labelnamepunct}
\printfield[citetitle]{title}}%
{\addsemicolon\space}
{\usebibmacro{postnote}}

\DeclareMultiCiteCommand{\footpartcites}[\mkbibfootnote]{\footpartcite}   {\addsemicolon\space}

\DeclareCiteCommand{\partcite}
{\usebibmacro{prenote}}
{\usebibmacro{citeindex}%
\mkbibbrackets{\usebibmacro{cite}}%
\setunit{\addnbspace}
\printnames{labelname}%
\setunit{\labelnamepunct}
\printfield[citetitle]{title}%
{\addsemicolon\space}
{\usebibmacro{postnote}}
\DeclareMultiCiteCommand{\partcites}{\partcite}{\addsemicolon\space}

\addbibresource{\jobname.bib}
\begin{document}
Each citation has two numbers.\footpartcite{unintentional}
And the order of citation is not correct. \ref{ftn:unintentional}

I dont know how to put unsrtnat style inside my preamble, because the system said it´s not existing.\footnote{\label{ftn:unintentional}\partcite{unintentional}}

And I have tried to define natbib separately \ref{ftn:unintentional}
But the system says I have already defined it with usepackage {biblatex}\footnote{\label{ftn:HP}\partcite{HP}}

The citation number inside text is not correct,\footpartcite{CrashStatistic} because only 4 citations have been used here \footpartcite{ASH}

Does anyone know how to solve them?\ref{ftn:HP} 

\printbibliography
\end{document}
4
  • 1
    Is something missing in your MWE? I get this error: File ended while scanning use of \blx@defcitecmd@iv. – totera Jan 2 '17 at 18:13
  • I didnt reproduce your error. Maybe you need to check your settings. You need to choose "pDFLatex+bib(la)+Pdflatex(x2)+show PDF" in the configuration. Otherwise it wont work @totera – Vivian Jan 2 '17 at 18:17
  • I'm not entirely sure I understand what you want. Do you only want the citation labels in the footnotes? Does sorting=none help a bit? – moewe Jan 2 '17 at 22:31
  • @moewe Thank you! it helps! The order of citation in footnote is now correct! – Vivian Jan 4 '17 at 16:14

Browse other questions tagged or ask your own question.