2

The following document produces a weird shaped \textbullet:

\documentclass{article}
\def\sfdefault{hlcn}
\begin{document}
\sffamily\Huge
\textbullet
\end{document}

enter image description here

Commenting out the chemmacros package, or the \sfdefault change produce a regular rounded one:

enter image description here

and I thought this was the Lucida Casual font... What is going on?

2
  • 2
    Try \usepackage[expert]{lucidabr}
    – user31729
    Jan 2 '17 at 20:53
  • Tried it... no change.
    – Jellby
    Jan 3 '17 at 8:40
2

This is part of what I get from the font table of hlcrn8c (the font used for font encoding TS1, family hlcn, series m and shape n):

enter image description here

The bullet corresponds to \char"88 (octal ´210). So it's a precise choice by Bigelow and Holmes.

I get the same with or without chemmacros (but as I don't have the obsolete lucidabr package, I used lucimatx).

You get a round bullet by undeclaring the association of \textbullet with TS1

\documentclass[noamssymb]{beamer}
\usepackage{lucimatx} % noamssymb is necessary with lucimatx
\renewcommand\sfdefault{hlcn}
\usepackage{chemmacros}
\UndeclareTextCommand\textbullet{TS1}
\DeclareTextCommandDefault\textbullet{$\bullet$}
\begin{document}
\begin{frame}
\Huge
\textbullet
\end{frame}
\end{document}

Without Lucida packages:

\documentclass{beamer}
\usepackage{chemmacros}

\renewcommand\sfdefault{hlcn}

\AtBeginDocument{%
  \UndeclareTextCommand\textbullet{TS1}%
  \DeclareTextCommandDefault\textbullet{$\bullet$}%
}

\begin{document}

\begin{frame}
\Huge
\textbullet
\end{frame}

\end{document}
4
  • Actually, I get the same "problem" behaviour without any lucida package, just with \def\sfdefault{hlcn}. Could it be my font installation is old/broken? But still, loading chemmacrosmakes a difference
    – Jellby
    Jan 3 '17 at 11:27
  • 2
    @Jellby What chemmacros does is to enable TS1. When it is enabled, the bullet is taken from the TS1 font, so the one in the picture.
    – egreg
    Jan 3 '17 at 11:29
  • And how would I enable the "curly" \textbullet without chemmacros? I can't just use \usepackage[TS1]{fontenc}...
    – Jellby
    Jan 3 '17 at 18:38
  • @Jellby \usepackage{textcomp}
    – egreg
    Jan 3 '17 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.