3

I seem to be encountering a strange problem where I have "builder": "simple" in my settings but when I build the document, LaTeXTools invokes the traditional builder. TraditionalBuilder: Engine: pdflatex. Invoking latexmk... done. Subsequently, it doesn't invoke BiBTeX and my references are all broken.

Here is the result of LaTeXTools System Check (minus the path variables)

Program      Location                                            Status     Version
-------      --------                                            ------     -------
sublime      /usr/bin/subl                                       available  Sublime Text Build 3126
latexmk      /usr/local/texlive/2016/bin/x86_64-linux/latexmk    available  Latexmk, John Collins, 22 April 2016. Version 4.45
pdflatex     /usr/local/texlive/2016/bin/x86_64-linux/pdflatex   available  pdfTeX 3.14159265-2.6-1.40.17 (TeX Live 2016)
xelatex      /usr/local/texlive/2016/bin/x86_64-linux/xelatex    available  XeTeX 3.14159265-2.6-0.99996 (TeX Live 2016)
lualatex     /usr/local/texlive/2016/bin/x86_64-linux/lualatex   available  This is LuaTeX, Version 0.95.0 (TeX Live 2016)
biber        /usr/local/texlive/2016/bin/x86_64-linux/biber      available  biber version: 2.6
bibtex       /usr/local/texlive/2016/bin/x86_64-linux/bibtex     available  BibTeX 0.99d (TeX Live 2016)
bibtex8      /usr/local/texlive/2016/bin/x86_64-linux/bibtex8    available  This is 8-bit Big BibTeX version 0.99d
kpsewhich    /usr/local/texlive/2016/bin/x86_64-linux/kpsewhich  available  kpathsea version 6.2.2
convert      /usr/bin/convert                                    available  ImageMagick 6.8.9-9 Q16 x86_64 2016-11-29 http://www.imagemagick.org
ghostscript  /usr/bin/gs                                         available  GPL Ghostscript 9.18 (2015-10-05)

Packages for equation preview  Status
-----------------------------  ------
standalone                     available
preview                        available
xcolor                         available
amsmath                        available
amssymb                        available
latexsym                       available
mathtools                      available

Builder  Status
-------  ------
simple   available

Builder Setting  Value
---------------  -----
display_log      False
linux            {}   
osx              {}   
windows          {}   

Viewer  Status     Location
------  ------     --------
evince  available  /usr/bin/evince

EDIT: Ignore the comment about BiBTeX and references. They work just fine.

  • Erh, latexmk will run bibtex when needed and compile until all references are updated. For us who does not use this editor, perhaps you should be a bit more detailed. Have you tested latexmk -pdf file.tex manually just to rule out editor issues. – daleif Jan 2 '17 at 18:57
  • 1
    Try to press ctrl+shift+b and select the LaTeX build system inside a tex document this will use the settings from your settings. You may have changed the build system to use the traditional builder. The traditional build uses latexmk, the simple builder directly pdflatex. As @daleif said it is a good start to check whether the bibtex problem comes from latexmk or an editor issue. – r-stein Jan 2 '17 at 19:31
  • @daleif, I updated the question... there wasn't actually an issue with BiBTeX and references. I had made a mistake. The core issue is that the traditional builder is being invoked from sublime text rather than the simple builder as specified in the settings. – Constantine Jan 2 '17 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.