4

The following code throws an error, "Package keyval Error: bookseries undefined. \ExecuteBibliographyOptions{bookseries=false}":

\documentclass{memoir}
\usepackage{lipsum}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\ExecuteBibliographyOptions{bookseries=false}
\begin{document}
\lipsum[1-2]
\end{document}

But if I don't use authordate, there's no error message. On the surface, there's no obvious reason why bookseries should not apply with the author-date format. So am I missing something, or is this a bug?

1

1 Answer 1

2

In the biblatex-chicago documentation on p. 61 we find

According to the Manual (14.128), the series field in book-like entries “may be omitted to save space (especially in a footnote).”

You will find that the option only applies to citations (in-text or footnotes) with the note style. The series will always appear in the bibliography regardless of the setting.

Thus it indeed does not make much sense to have the option in the author-date styles. You will probably not have (many) full citations in your document with that style and the bibliography, where the series could appear is unaffected by the option.

But we can make that option apply to the bibliography in authordate

\providetoggle{cms@bookseries}
\DeclareBibliographyOption{bookseries}[true]{%
  \settoggle{cms@bookseries}{#1}}%

\DeclareEntryOption{bookseries}[true]{%
  \settoggle{cms@bookseries}{#1}}%

\renewbibmacro*{ser+num}{%
  \iftoggle{cms@bookseries}%
  {\printfield{series}%
    \printfield[sernum]{number}}%
  {}}%

Note: If you are using the notes style you will only need the very last \renewbibmacro, you can drop the rest. Then the bookseries option will apply to the bibliography as well.

Remember to put the code before you actually execute the bibliography option.

In full

\documentclass{article}
\usepackage[authordate,backend=biber]{biblatex-chicago}

\providetoggle{cms@bookseries}
\DeclareBibliographyOption{bookseries}[true]{%
  \settoggle{cms@bookseries}{#1}}%

\DeclareEntryOption{bookseries}[true]{%
  \settoggle{cms@bookseries}{#1}}%

\newbibmacro*{ser+num}{%
  \iftoggle{cms@bookseries}%
  {\printfield{series}%
    \printfield[sernum]{number}}%
  {}}%

\ExecuteBibliographyOptions{bookseries=false}
\addbibresource{biblatex-examples.bib}
\begin{document}
\cite{coleridge}
\printbibliography
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .