2

I was compiling a file in Asymptote. As a minimal working example, consider anything that has to label a point like

settings.outformat="pdf";
dot("$A$", (0,0));

It spits the error

Unfortunately, the package miktex-dvips-base could not be installed.Please check the log file:
C:/Users/.../AppData/Local/MiKTeX/2.9/miktex/log/dvips.log
C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\dvips.exe: ! Couldn't find header file: tex.pro
C:\Program Files (x86)\Asymptote/plain_shipout.asy: 87.10: runtime: shipout failed
[Finished in 14.2s]

And the log file says this:

2017-01-03 18:05:03,374+0800 INFO  dvips - installing package miktex-dvips-base triggered by dvips\base\tex.pro
2017-01-03 18:05:05,623+0800 INFO  dvips - mpm: starting package maintenance...
2017-01-03 18:05:05,623+0800 INFO  dvips - mpm: installation directory: "C:\Program Files (x86)\MiKTeX 2.9"
2017-01-03 18:05:05,623+0800 INFO  dvips - mpm: package repository: ftp://ftp.u-aizu.ac.    jp/pub/tex/CTAN/systems/win32/miktex/tm/packages/next/
2017-01-03 18:05:06,040+0800 INFO  dvips - mpm: lightweight database digest: 8b7e5e14ebc0805350eddfca3bbc71bc
2017-01-03 18:05:06,106+0800 FATAL dvips - Unknown archive file size.
2017-01-03 18:05:06,106+0800 FATAL dvips - Info: package="miktex-dvips-base"
2017-01-03 18:05:06,106+0800 FATAL dvips - Source: libraries\miktex\packagemanager\internal.h
2017-01-03 18:05:06,107+0800 FATAL dvips - Line: 483

When I open mpm and try to install the package manually (yes, I tried refreshing FNDB, updating the formats, synchronizing &c) it spits out the same error:

MiKTeX Problem Report
Message: Unknown archive file size.
Data: package="miktex-dvips-base"
Source: libraries\miktex\packagemanager\internal.h
Line: 483
MiKTeX: 2.9
OS: Windows 7 Professional, 64-bit, build 7600
Invokers: explorer/mo
SystemAdmin: yes
PowerUser: no
Root0: C:\Users\...\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\...\AppData\Local\MiKTeX\2.9
Root2: D:\Documents\tex\root
Root3: C:\ProgramData\MiKTeX\2.9
Root4: C:\Program Files (x86)\MiKTeX 2.9
UserInstall: C:\Users\...\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\...\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\...\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files (x86)\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9

I’ve tried to install miktex-dvips-base manually, however I can’t find the file. It seems to be deprecated, if so, how can I make it so that Asymptote doesn’t have to rely on the file?

1
  • 2
    Miktex has reorganized the packages in november. The header files are now in "dvips". You need to synchronize your offline database with the online database (package manager, admin + user version, menu repositories). Jan 3, 2017 at 10:33

1 Answer 1

1

Fixed it – the solution was to install the package dvips. I synchronized my offline database and installed dvips with mpm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .