1

I have a problem using Biblatex/Biber. First I used:

\usepackage[backend=biber]{biblatex}

Everything worked fine. Then, I wanted to change the style to chem-acs. This gave me the warning: Empty bibliography.

Tried changing the style to authortitle, this didn't give me the error. What am I doing wrong? Thank you!

Info: MacOSX version 10.11.5, Texmaker version 4.5

2
  • 1
    Try deleting the temporary files (.aux, .bcf, .bbl) and recompile from scratch. If the error keeps coming back, please try and provide an MWE. Have a look at the .log and .blg files.
    – moewe
    Jan 6, 2017 at 15:05
  • Thank you! I only deleted the .bcfand .bbl files and then compiled it again. Deleting all three files solved the problem :-)
    – Caroline
    Jan 6, 2017 at 15:11

1 Answer 1

2

This is a subtle one: it's caused by the change of sorting order between the standard styles and the chem-acs one. The standard styles do sorting = nty, the ACS one sorting = none. This causes some issues with data left in the .aux file, which is where the error comes from. (You can see the issue by simply adding sorting = none after a LaTeX/Biber/LaTeX cycle with no style explicitly loaded, as that does sorting = nty implicitly.)

As noted in a comment, deleting the .aux, .bbl and .bcf files (or simply ignoring the error, getting to the end of the run and re-running Biber) clears the issue. However, this should at the very least give a better error message: I've logged in the biblatex issue tracker.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .