3

I'v got problems with KOMA-Script and cyrillic (I guess).

Commands \paragraph (as well as \section, \subsection, etc.) don't display russian text. Is this a known issue?

I am using SublimeText, LatexTools, MikTeX and Sumatra

\documentclass[fontsize=5,parskip=never]{scrartcl}

\usepackage[paper=a5paper,landscape, left=1mm, top=4mm]{geometry} 

\usepackage{multicol}       

\usepackage{setspace}
\singlespacing% одинарный интервал

\usepackage{enumitem}
\setlist{nosep} % or \setlist{noitemsep} to leave space around whole list

\usepackage{fontspec}
\setmainfont{Arial}


\usepackage{cmap}                   % поиск в PDF
\usepackage[T2A]{fontenc}           % кодировка
\usepackage[utf8]{inputenc}         % кодировка исходного текста
\usepackage[russian]{babel} % локализация и переносы
%\usepackage{fontspec}              % otf шрифты
\usepackage{textpos}                % текстовые блоки
%\usepackage[export]{adjustpage}        % положение картинок 
\usepackage{xcolor}                 % цвет





\begin{document}




\begin{multicols*}{5}

\Large \textbf{Flush Shutter DC} \normalsize 



\large \textbf{Электробезопасность} \normalsize     %% I SEE THIS (TEXTBF WORKS WELL)
\paragraph{ПАРАГРАФ}                                %% I DONT SEE THIS
\paragraph{PARAGRAPH}                               %% I SEE THIS

text


\end{multicols*}
\end{document}
  • your log will show Missing character: There is no П in font [lmsans10-bold]:+tlig;! You need to specify a heading font with support for Cyrillic – David Carlisle Jan 9 '17 at 7:56
  • 1
    do not use \usepackage[T2A]{fontenc} % кодировка \usepackage[utf8]{inputenc} % кодировка исходного текста with xetex, neither inputenc nor fontenc should be used here. (although they are not the cause of the problem here) – David Carlisle Jan 9 '17 at 7:57
4

The document is using latin modern bold sans serif for titles and that font does not have Cyrillic.

The log warns

Missing character: There is no П in font [lmsans10-bold]:+tlig;!

You could select a different font using the classes heading setup features or generally avoid the problem with the egregdoesnotlikesansseriftitles option.

In this case you still get sans titles as you have specified Arial as the main document font.

enter image description here

\documentclass[
  fontsize=5,
  parskip=never,
  egregdoesnotlikesansseriftitles
]{scrartcl}

\usepackage[paper=a5paper,landscape, left=1mm, top=4mm]{geometry} 

\usepackage{multicol}       

\usepackage{setspace}
\singlespacing% одинарный интервал

\usepackage{enumitem}
\setlist{nosep} % or \setlist{noitemsep} to leave space around whole list

\usepackage[russian]{babel} % локализация и переносы
\usepackage{fontspec}
\setmainfont{Arial}


%\usepackage{fontspec}              % otf шрифты
\usepackage{textpos}                % текстовые блоки
%\usepackage[export]{adjustpage}        % положение картинок 
\usepackage{xcolor}                 % цвет





\begin{document}



\begin{multicols*}{5}

\subsection*{Flush Shutter DC}

\subsection*{Электробезопасность}    %% I SEE THIS (TEXTBF WORKS WELL)
\paragraph{ПАРАГРАФ}                                %% I DONT SEE THIS
\paragraph{PARAGRAPH}                               %% I SEE THIS

text


\end{multicols*}
\end{document}
3

You are just forgetting to set the sans serif font:

\documentclass{scrartcl}

\usepackage{fontspec}
\usepackage[russian]{babel} % локализация и переносы

% settings
\setmainfont{Arial}
\setsansfont{Arial}

\begin{document}

\textbf{Flush Shutter DC}

\textbf{Электробезопасность}

\paragraph{ПАРАГРАФ}

\paragraph{PARAGRAPH}

text

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.