2

I used \DeclareTOCStyleEntry{dottedtocline}{chapter} in order to get dots on chapters. Unfortunately the chapter entries aren't bold anymore. How to I get the it bold an keep the lines? The manual didn't help me on that one.

(I managed to do it with `tocstyle, but I don't want to use an alpha package...)

Thanks!

\documentclass{scrbook}
\usepackage[ngerman]{babel}
\usepackage{blindtext}
\DeclareTOCStyleEntry{dottedtocline}{chapter}

\begin{document}
\tableofcontents
\addchap{Einleitung}
\addchap{Hinweise}
\addsec{bla}
\blinddocument
\end{document}

enter image description here

1
  • AFAIK dottedtocline is only a compatibility style. AFAIR the KOMA-Script classes use style tocline or aliases and derived styles for each toc entry level. Commented Jan 9, 2017 at 11:26

1 Answer 1

3

Simply use option toc=chapterentrywithdots: (see sec 3.9 v3.15)

\documentclass[toc=chapterentrywithdots]{scrbook}
\usepackage[ngerman]{babel}
\usepackage{blindtext}

\begin{document}
\tableofcontents
\addchap{Einleitung}
\addchap{Hinweise}
\addsec{bla}
\blinddocument
\end{document}

chapter entries with dots

It does something like

\RedeclareSectionCommand[toclinefill=\TOCLineLeaderFill]{chapter}

so it does not change the style of the entries but only changes the linefill feature of the TOC entry style.

1
  • Just noted: with \DeclareTOCStyleEntry[beforeskip=1pt]{tocline}{chapter} the spacings will be the same everywhere. :)
    – Marcel
    Commented Jan 9, 2017 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .