5

I have this problem on of my paragraphs in my document. There is a large blank space in between the first and the second word in the paragraph. Here is the code:

\documentclass[12pt, twocolumn, english]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{enumitem}
\usepackage[margin=2.0cm]{geometry}
\usepackage{hyphenat}

\pretolerance=10000
\tolerance=2000 
\emergencystretch=10pt

\begin{document}
\subsection{Haptic Devices}
\paragraph{}
Haptic interfaces are devices that uses the modality of touch for input and        output in interaction. These devices provide better immersion and presence in    virtual environments\cite{Tsalamal}, but also bridges issues of use when other sensory modalities are unavailable, such as vision for the blind\cite{Sjostrom}. Haptic devices that are either attached, or with limited or no direct contact are currently being explored \cite{Tsalamal}. Devices that are attached or provide limited contact allow more freedom but limited force rendering. A number of non-contact devices have promising, but share the issue of some of the limited-contact devices which is the restricted workspace\cite{Tsalamal}. 
\end{document}

With this code the output looks like this:

enter image description here

As you can see there is a large gap between the first and the second word. Does anyone know how to prevent this from happening?

  • 1
    It may comes from the \pretolerance=10000. Try to comment it. – Jérôme Dequeker Jan 13 '17 at 13:15
  • 1
    And why do you want to suppress all hyphenation operations? – Mico Jan 13 '17 at 13:20
  • 2
    Try \usepackage[none]{hyphenat} to suppress hypenations. – Jérôme Dequeker Jan 13 '17 at 13:21
  • 2
    I suggest that you keep the hyphenation, but load the package microtype instead. You will then reduce the numbers of hyphenation to a minimum, unless you write a lot of log words. Big, white spaces in the text is ugly, and reduce the readability of your text. If you insist not to use hyphenation, you should set your text ragged right. – Sveinung Jan 13 '17 at 13:35
  • 1
    More often than not, good typography is about striking a balance between conflicting criteria for what may 'look good'. The preference ordering you impose -- "[I don't want hyphens because] in my opinion [the text] looks better without them" -- precludes any kind of balance. If you absolutely don't want hyphens, you have to accept that other typographic problems will show up, e.g., large and highly distracting inter-word gaps. Eventually, you will come to the conclusion that disallowing all hyphenation is not better after all. – Mico Jan 13 '17 at 13:41
4

Delete \pretolerance=10000 and \tolerance=2000, and to suppress hyphenation to the entire document, use \usepackage[none]{hyphenat} (see this question: How to prevent LaTeX from hyphenating the entire document?).

  • I wrote \usepackage[english]{hyphenat} because I saw that the OP uses babel and the text is written in english – Alessio Jan 13 '17 at 13:27
  • 2
    \usepackage[english]{hyphenat} gives me an error – Jérôme Dequeker Jan 13 '17 at 13:31
  • 3
    @Alessio By the way, I think you should ask me to post an answer if my comments solve the problem instead of posting your own answer containing all I said in comments, just a few minutes before. – Jérôme Dequeker Jan 13 '17 at 13:33
  • 2
    @martin36 The gap in line 3 comes from the fact that you disabled hyphenation. – user36296 Jan 13 '17 at 13:35
  • 1
    @martin36 The only way to avoid this gap is to allow hyphenation – Jérôme Dequeker Jan 13 '17 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.