12

I first installed TeXstudio, and then TeX Live-full,

but TeXstudio can't find any distribution.

OS: Ubuntu 16.04 LTS

root@user1:latex -version
pdfTeX 3.14159265-2.6-1.40.16 (TeX Live 2015/Debian)
kpathsea version 6.2.1
Copyright 2015 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh     (pdfTeX).
Compiled with libpng 1.6.17; using libpng 1.6.17
Compiled with zlib 1.2.8; using zlib 1.2.8
Compiled with poppler version 0.41.0

root@user1:tex -version
TeX 3.14159265 (TeX Live 2015/Debian)
kpathsea version 6.2.1
Copyright 2015 D.E. Knuth.
There is NO warranty.  Redistribution of this software is
covered by the terms of both the TeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the TeX source.
Primary author of TeX: D.E. Knuth.

Should I manually set the "Command" config of TeXstudio?

Someone says that I should set PATH as:

PATH=/usr/local/texlive/2016/bin/i386-linux:$PATH 

But I found there's no /local/texlive in this folder.

enter image description here

enter image description here

12
  • I don't think the debian packaged version installs in /usr/local what does which tex report as the location of tex? Commented Jan 13, 2017 at 14:34
  • It returns: /usr/bin/tex, so what should I set my PATH as?
    – null
    Commented Jan 13, 2017 at 14:38
  • it is hard to imagine that /usr/bin is not already in your path Commented Jan 13, 2017 at 14:47
  • I think that is already on my PATH, but I really don't know why Texstudio can't find distribution.
    – null
    Commented Jan 13, 2017 at 14:49
  • 1
    I would install texstudio after texlive so TS could find TL.
    – tatojo
    Commented Feb 11, 2017 at 4:55

1 Answer 1

7

According to your screenshot, you installed TeX Live 2015, therefore I think the directory you add to the path variable, "/usr/local/texlive/2016/bin/i386-linux", makes no sense.

My solution (it worked for me) is following:

  1. call which latex on your terminal
  2. Copy the path of its output, e.g., /usr/local/texlive/2017/bin/x86_64-linux/ (without the trailing 'latex'), in your TexStudio Configuration PATH. You should select Options > Configure TexStudio > Build > Commands ($PATH) As I show you in the picture below. (Notice that in order to see all options you must click on the box Show Advanced Options at the bottom left corner) enter image description here

Then just try to build your LaTeX file. Enjoy it!

6
  • I have fedora and this is not working for me Commented Jan 29, 2022 at 22:05
  • @SohamChatterjee what is not working? You only have two steps ;). The which command is a generic Linux command... Commented Jan 31, 2022 at 18:22
  • I followed the steps you said..but after adding the path in texstudio it is still showing no latex distribution Commented Jan 31, 2022 at 20:11
  • It might be a LaTeX installation problem. Try to execute the path given by which latex, that is, enter such path in terminal (for example, in my case is /usr/bin/latex). If latex is correctly executed it will output something like This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian). If not, then the problem might be at LaTeX installation not at TeXStudio Commented Feb 1, 2022 at 10:09
  • I when i execute which latex it shows me /usr/local/texlive/2021/bin/x86_64-linux/latex nothing else and on executing pdflatex i get This is pdfTeX, Version 3.141592653-2.6-1.40.22 (TeX Live 2021) (preloaded format=pdflatex) restricted \write18 enabled. ** Commented Feb 1, 2022 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .