2

I hope you're doing great. I have the following problem when I try to compile my document, using the spanish babel package.

\documentclass[12pt,a4paper]{article}
\usepackage[latin1]{inputenc}
\usepackage[spanish, es-tabla]{babel}
\usepackage[margin=1cm,font=normalsize,labelfont=bf]{caption}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage[left=2.5cm,right=2.5cm,top=2.5cm,bottom=2.5cm]{geometry}
\usepackage{array}
\usepackage{enumerate}
\usepackage[shortlabels]{enumitem}
\usepackage{booktabs}
\usepackage{subcaption}
\usepackage{subfig}
\usepackage{graphicx}
\usepackage{subfig}
\usepackage{bm}
\usepackage{multirow}
\usepackage{lscape}
\usepackage{natbib}
\usepackage{tikz}
\usepackage[makeroom]{cancel}
\usetikzlibrary{shapes.geometric,arrows}
\providecommand{\abs}[1]{\lvert#1\rvert}
\setlength\parindent{0pt}

\tikzstyle{startstop}=[rectangle, rounded corners, minimum width=3cm, minimum height=1cm, text centered, text width=5cm, draw=black, fill=red!30]

\tikzstyle{io}=[trapezium, trapezium left angle=70, trapezium right angle=110, minimum width=3cm, minimum height=1cm, text centered, text width=3cm, draw=black, fill=blue!30]

\tikzstyle{process}=[rectangle, minimum width=3cm, minimum height=1cm, text centered, text width=5cm, draw=black, fill=orange!30]

\tikzstyle{decision}=[diamond, minimum width=3cm, minimum height=1cm, text centered, text width=4cm, draw=black, fill=green!30]

\tikzstyle{arrow}=[thick,->,>=stealth]

\begin{document}
El término agua generalmente se refiere a la sustancia en su estado líquido, aunque la misma puede hallarse en su forma sólida llamada hielo, y en su forma gaseosa denominada vapor. Es una sustancia bastante común en el universo y el sistema solar, donde se encuentra principalmente en forma de vapor o de hielo. Es esencial para la supervivencia de todas las formas conocidas de vida. ¿Qué opina usted de ésto?



\bibliographystyle{apalike}
\bibliography{ref_hw10}
\end{document}

Some error messages I get when compiling are:

! Undefined control sequence. \StartBabelCommands
! LaTeX Error: Missing \begin{document}.See the LaTeX manual or LaTeX Companion for explanation.Type H <return> for immediate help.... \StartBabelCommands

! Undefined control sequence. \AddBabelHook

The log file is available here: http://share.udec.cl/server/php/files/mkuschel/compartir/hw_10.log

What should I do? Thanks in advance

closed as off-topic by Andrew Swann, TeXnician, Bobyandbob, Troy, moewe May 15 '18 at 9:39

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This document works with TeXLive 2016 under Linux; there is only one error message saying that subcaption cannot be used with subfig. Maybe updating your TeX distribution helps ... – gernot Jan 13 '17 at 21:13
  • unrelated to your error but don't load both enumerate and enumitem package (they both try to redefine the enumerate environment) – David Carlisle Jan 13 '17 at 21:26
  • You have incongruences on your TeX systems: it seems you have updated spanish.ldf (2016/03/03 v5.0p) but not the core babel (2008/07/08 v3.8m), which is currently 2016/04/23 3.9r. Do a thorough update to your MiKTeX. – egreg Jan 13 '17 at 22:27
  • I solved the problem using the "Package Manager" and then downloaded the respective babel package. Thanks for all – mkuschel Jan 14 '17 at 3:12
  • 4
    I'm voting to close this question as off-topic because as it is solved by updating the packages. – Andrew Swann May 15 '18 at 7:49

Browse other questions tagged or ask your own question.