2

The official Solus repository provides only texlive-base (current version: 20160523b-6) for installation. How can one install texlive-full (current version: 2016) on Solus Linux?

  • 1
    Welcome! Just install TeX Live from upstream and forget your distro's (non-)packages. You will possibly need to provide a dummy package to keep your package manager happy, but otherwise it is all quite straightforward. – cfr Jan 15 '17 at 2:41
  • 2
    See tex.stackexchange.com/questions/1092/…. Although it assumes a Debian-based system, it can be adapted for other distros pretty easily. (I've never heard of Solus before, so maybe it is Debian-based, but, if not, you'll just need to translate it into your distro's terms.) – cfr Jan 15 '17 at 2:43
  • @cfr Solus is not debian based, its a fairly new os that is being developed from scratch. Also it uses a new package manager --eopkg. This in turn implies that either you can install packages listed in the official repo or you build it from source! – Orion Jan 16 '17 at 14:38
  • As I say, it is just a question of translating it for your package manager, be it pacman, dnf, eopkg or whatever. The principle is the same regardless. – cfr Jan 16 '17 at 20:23
3

texlive-full installation

The following provides a step-by-step guide for installing texlive-full on Solus Linux. Plase see this texlive-full quick install for detailed instructions.

There are a number of ways to install texlive-full like network install, iso install, etc. A more detailed description can be found in above link. Assuming network install, the first step is to download the installer and run the install-tl script.

After the installation is done, the next step is setup the PATH variable. Add the following two lines to your bashrc file located in your home directory. Full path of the bashrc file is: /home/username/.bashrc.

PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH

export PATH

Note

  1. Please do not set the PATH variable as PATH=$PATH:/usr/local/texlive/2016/bin/x86_64-linux. The reason for this will be explained later.
  2. Choose the syntax appropriate for your shell, your installation directory, and your platform for setting up the PATH variable. For example if you have a 32-bit platform use PATH=/usr/local/texlive/2016/bin/i386-linux:$PATH

Next, logout and then after login check if the the PATH variable is properly set or not, run this command: echo $PATH. This should output something similar to:

/usr/local/texlive/2016/bin/x86_64-linux:/usr/local/bin:/usr/bin:/bin

This is it, check if latex is properly installed by running the command latex. This should output something like:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (TeX Live 2016) (preloaded format=latex) restricted \write18 enabled. **

Setting up TeXstudio in Solus linux

The above was the easy part. Most of us work with an integrated editor such as TeXstudio when working with latex. The following guide shows how to setup an editor such as TeXstudio to work with texlive-full in Solus linux. Although the following is written for TeXstudio in mind, it should work with other editors also with appropriate changes.

Install TeXstudio from the software center. The problem is that this will also install the texlive-base package present in the Solus repository. The reason is that TeXstudio depends upon the texlive-base package and the Solus software center does not recognize the texlive-full installation that is already installed on the system (if you followed the guide till now, that is). I couldn't find a workaround this. No worries though, proceed with the installation of both TeXstudio and texlive-base package.

After the install is done, you would have two different versions of texlive installed on the system.

  1. texlive-full which was installed manually.
  2. texlive-base which was installed along with TeXstudio.

Now, if you compile a latex document via the terminal it will compile via the texlive-full package. (Hence the reason for setting up the PATH variable as PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH). But if you compile your document using TeXstudio, then it will compile via the texlive-base package.

Hence, the next step is to manually configure TeXstudio to use the texlive-full package.

  1. Open TeXstudio and go to Options -> Configure TeXstudio -> Commands
  2. There you will see the different programs available in the texlive package.
  3. Click on the Select Program icon on the right side of the pane, and browse to the texlive-full installation directory. in my case, this is : /usr/local/texlive/2016/bin/x86_64-linux/. Find and select the appropriate program for each of: latex, pdflatex, xelatex, lualatex and you are done

That's it !!!

  • 1
    This should not be necessary. Where exactly was that path change made? In Ubuntu for example (I don't know solus), you can add it to your location dot-profile or the global version /etc/profile. Logout and in again for it to be effective. A lot of users add the path change to dot-bashrc, which does not affect texstudio when texstudio is started via a menu or doubleclicking a tex file. Then you do not need full paths for stuff in the texstudio configuration.. This is a very common error on Linux when setting up texlive. – daleif Jan 15 '17 at 7:48
  • @daleif you are absolutely right that path change done in .profile doesn't affect TeXstudio. For TeXstudio to use the texlive-full package instead of the texlive-base package we need to configure TeXstudio manually. This explained in the second part of the guide. The path change is done is so that that texlive-full package is used when someone doesn't want to compile a latex document via the command line without the need for a text editor like TeXstudio. – Orion Jan 16 '17 at 13:39
  • It should be the other way round. Things in .bashrc should not affect texstudio if texstudio is loaded via a menu or similar. If configured correctly, it should not be necessary to manually set those paths in TeXStudio. A normal naïve user will not know how to do that (they don't know where LaTeX is), it should be enough to have the correct paths set up. Exactly what is Solus Linux? – daleif Jan 16 '17 at 13:53
  • @daleif I'm confused here! You agree with me that changes made in the PATH variable in .bashrc or .profile do not affect editors like TeXstudio right? – Orion Jan 16 '17 at 14:00
  • No, changes to .profile should work, it does on Ubuntu, but you have to log out and in again for changes to do anything. .profile (again on Ubuntu) is only read at login. I've tried to install Solus Linux in a VM, but is unable. – daleif Jan 16 '17 at 14:10
2

The full installation of TeX Live is available in Solus. It contains the full content of the 1.9GB texlive-20160523b-texmf.tar.xz (minus docs)

Installing these packages would result in the full TeX Live install.

eopkg list-available | grep texlive

I am in the process of creating a TeX Live meta package so that you can install the complete TeX Live more conveniently by installing the texlive-all package. This will be available sometime in the next few days.

  • That does not explain why the OPs texstudio sees no latex at all. – daleif Jan 17 '17 at 7:06
  • @sunnyflunk The package that you mentioned is not the full texlive package. It does not contain many packages and my Latex document fails to compile with it stating that packages are missing. Moreover I don't think that texlive-full package is only 1.9GB, the official texlive-full-2016 iso is of 3.1GB. – Orion Jan 18 '17 at 12:16
  • @Orion The reason the iso is larger as it contains 16 copies of the same packages in different binary formats. Are you able to provide a sample doc to me via the forums as I'd like to resolve any issue people experience with TeX Live – sunnyflunk Jan 19 '17 at 0:39
1

You can simply install TexStudio without installing TeX Live from the Solus repositories.

Once you've installed TeX Live (the install script from the TeX Live homepage works fine), install the dependencies of TexStudio except TexLive using eopkg:

sudo eopkg it zlib poppler-qt5 qt5-base qt5-script libx11 libstdc++ zlib poppler-qt5 qt5-base qt5-script libx11 libstdc++

Then install TexStudio without dependencies:

sudo eopkg it --ignore-dependency texstudio

Since you've already manually installed the needed dependencies, the only thing that won't be installed is texlive-base.

You'll still have to fix the PATH as mentioned by Orion, and you still have to manually set the various command properties in the TexStudio settings, but you won't have two competing TeX Live installations on your system.

0

This is just a comment, a bit too long.

Have I understood you right:

  1. You manually installed upstream texlive? Where was it installed? If my memory is correct it installs in /usr/local/texlive/2016 by default.
  2. Did you ask it to make soft lines in common places? (not recommended)
  3. You installed texstudio which in addition also installed texlive-base presumably from Debian (not because texstudio needs it, but because it us listed as recommended)

Is this correct?

Thus you now have two latex installations. And we need to use the right one.

As mentioned I'm not familiar with solus Linux, and for some reason it does not like my version of virtualbox, so I cannot test it.

Under Ubuntu it is enough to add the path change to dot-profile (adding it also to dot-bashrc does not hurt, but it alone is often not enough). But this being a different Linux, we do not know if dot-profile or dot-bashrc is even being used.

  • @Orion I give up trying to help on this issue. I cannot get it to work on my home laptop either, though I could install it, it will not let me log in (presumably an X crash). From the forums one an read that this is not an OS designed to be used in a virtual setting, so much for testing. We will need a fix env in order to test texstudio. – daleif Jan 17 '17 at 16:44
  • thanks for trying though :) – Orion Jan 18 '17 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.