1

I have inherited a latex stylesheet and document, in it, the bibliography seems to detect when there are multiple works in a row, with the same author, when this occurs it replaces the author with a line, i.e:

Crisp, Oliver. Divinity and Humanity. New York: Cambridge, 2007.
——— God Incarnate. New York: T&T Clark, 2009.
——— The Word Enfleshed: Exploring the Person and Work of Christ. TBC: TBC, 2016.

I wonder if anyone can point me in the right direction to start working out how to get rid of this behaviour? I notice there is this in the .sty file:

\setlength\bibindent{\parindent}

\renewcommand\@openbib@code{%
        \setstretch{1}
        \singlespacing
        \setlength\leftmargin{\bibindent}
        \setlength\itemindent{-\bibindent}
        \addtolength\itemindent{\labelsep}
        \addtolength\itemindent{\labelwidth}
        \setlength\itemsep{\tf@singlelineskip}
        \setlength\parsep{\z@}}

% set formatting defaults and pass options
\PassOptionsToPackage%
        {isbn=false, autolang=other, footmarkoff, backend=biber}%
        {biblatex-chicago}
\if@authordateformat
        \PassOptionsToPackage{authordate}{biblatex-chicago}
\fi

%  adjustments to \printbibliography formatting
\if@appendbibformat
        \AtEndPreamble{%
                \@ifpackageloaded{biblatex}%
                        {%
                                \if@authordateformat
                                        \DefineBibliographyStrings{english}{%
                                                bibliography = {References}}
                                \else
                                        \DefineBibliographyStrings{english}{%
                                                references = {Bibliography}}
                                \fi
                                \renewcommand{\bibsetup}{%
                                        \addcontentsline{toc}{\tf@topsecname}{\bibname}
                                        \singlespacing}
                                \renewcommand{\bibitemsep}{1\baselineskip}
                                \renewcommand{\bibhang}{0.5in}
                        }{}}
\fi
  • Please note that often it is very important to know which style you are using. With questions like this it is a very, very good idea to provide an MWE so that we can see what style you are using and what other set-up you have, we can then also test our suggestions with for your specific situation making sure that they work for you. – moewe Jan 15 '17 at 15:03
  • For other styles, see Get full name twice in Bibliography – moewe Jan 15 '17 at 15:04
2

Since you are using the SBL style biblatex-sbl try

\AtBeginBibliography{\renewbibmacro{dashcheck}[2]{#2}}

alternatively, you could also go with

\renewbibmacro*{bbx:dashcheck}[2]{#2}
1
 \usepackage[...,dashed=false]{biblatex}
  • When I add it, it is now, \usepackage[style=sbl,backend=biber,dashed=false]{biblatex} but that doesn't compile. However, it does give me a clue as to where to look in the documentation! Thanks – Jacob Jan 15 '17 at 12:07
  • 1
    by the way: backend=biber is the default – user2478 Jan 15 '17 at 12:27
  • BTW, there's a good reason the dashed=false package option doesn't work... It was only implemented recently and is only available in the development version of biblatex-sbl, not the one in CTAN. If you need the development version you can grab it from github.com/dcpurton/biblatex-sbl/tree/dev (It will be a little while before I get to the next release.) – David Purton Feb 25 '17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.