2

Normally the output should be appear like

enter image description here

But actually it appears like

enter image description here

\documentclass{article}

\usepackage{arabxetex, arabtex}

\setromanfont[Mapping=tex-text]{Times New Roman}
\newfontinstance\farsifont[Script=Arabic]{Times New Roman}
\newfontinstance\arabicfont[Script=Arabic]{Times New Roman}

\begin{document}
\begin{farsi}
ایضاً
\end{farsi}

\end{document}
  • 1
    ! Undefined control sequence \newfontinstance – Salim Bou Jan 15 '17 at 14:45
  • I can compile the file with xelatexwithout error. – Name Jan 15 '17 at 14:48
  • I'm used to use \newfonfamily not \newfontinstance – Salim Bou Jan 15 '17 at 14:50
  • 1
    To enable vocalization you need to insert fullvoc option \usepackage[fullvoc]{arabxetex} – Salim Bou Jan 15 '17 at 14:52
  • 1
    Rather then fullvoc you can use voc – Salim Bou Jan 15 '17 at 14:59
3

By default vocalization of Arabic letters is deactivated with arabxetex, you can activate it with \usepackage[voc]{arabxetex}, if you want a full vocalized text you can get it with \usepackage[fullvoc]{arabxetex}

Note that \newfontinstance is replaced with \newfontfamily after fontspec v2

\documentclass{article}

\usepackage[voc]{arabxetex}

\setromanfont[Mapping=tex-text]{Times New Roman}
\newfontinstance\farsifont[Script=Arabic]{Times New Roman}
\newfontinstance\arabicfont[Script=Arabic]{Times New Roman}

\begin{document}
\begin{farsi}
ایضاً
\end{farsi}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.