0

I have a lot of different folders with different projects and different .tex documents. For all of them I am using the same bib-file (mainbib.bib). Since it gets a bit tedious to always keep the bib-file in the same folder as the .tex, I thought I could try the do the following:

I copied my mainbib.bib file into the the root's directory of MikTeX's bibtex folder, that would be something like

C:\Program Files (x86)\MiKTeX 2.9\bibtex\bib\bibtex

since - at least I thought so - MikTeX would look into this folder while searching for the file (before it eventually would find it in the same folder as my .tex). But it doesn't find the mainbib.bib file. Is there anything I did wrong or does this approach not work at all?

I am using Windows 10 and MikTeX 2.9 (TeXworks) and for typesetting latexmk.


\documentclass[a4paper]{article}
\usepackage{geometry}
\geometry{a4paper,left=30mm,right=25mm, top=2cm, bottom=2cm} 
\parindent0mm  
\usepackage{tabularx}
\usepackage{imakeidx}
\usepackage{cite}
\usepackage{amsmath}
\usepackage{hyperref}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[english]{babel}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{bbm}
\usepackage{amsthm}
\usepackage{color}
\usepackage[onehalfspacing]{setspace}
\usepackage{graphicx}
\usepackage{framed, color}

\makeatother
\makeindex 
\begin{document}
\section{Test}
\cite{test}

\bibliography{mainbib}
\bibliographystyle{plainnat}
\end{document}

  • any additional info in the log-files? – naphaneal Jan 16 '17 at 19:55
  • @naphaneal nothing which would make it any clearer...except that sometimes it looks in C:\Program Files (x86) and sometimes in C:\Users\user190080\AppData\Roaming - so alternating directories and I only tried to put the file into the first one...might give a shot in the second as well. – user190080 Jan 16 '17 at 20:05
  • 1
    You'd better create somebibfiles subdirectory of your working directory, or in your local texmf root. You should never put whatever in the main root: it might be deleted on updates. – Bernard Jan 16 '17 at 20:13
  • @Bernard That's definitely a good point - for now, I just wanted to test whether it actually works or not. Am I right that the working directory depends on what editor I actually use, like TeXworks? – user190080 Jan 16 '17 at 22:03
  • 1
    You need to update the FNDB in admin mode if you put the bib there. But it is better to use a local texmf tree. Create localtexmf/bibtex/bib and add localtexmf as a new root in miktex settings. – Ulrike Fischer Jan 17 '17 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.