4

At the moment I struggle with creating my bibliography. I always get the message "WARN - No data sources defined!" from Biber.

So what did I try to solve my problem?

  • I updated Biber, BibLaTeX and natbib in the package manager of MikeTeX
  • I made a small example to make sure the problem is not related with anything else in my original LaTeX file but the problem stayed the same
  • I looked up the message via google and was trying solutions that others helped, but none did work for me yet

So I hope you guys see my mistake or can tell me what to do different.

So here is the example:

\documentclass[a4paper]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}

\usepackage[square]{natbib}

\begin{document}

    \citep[S.~15]{Hevner2004}

    \bibliographystyle{natdin}

    \bibliography{complete}

\end{document}

Content of complete.bib:

@article{Hevner2004,
 author = {Hevner, A. R. and March, S. T. and Park, J. and Ram, S.},
 title = {{Design Science in Information Systems Research}},
 journal = {MIS Q.},
 issue_date = {March 2004},
 volume = {28},
 number = {1},
 month = {mar},
 year = {2004},
 pages = {75--105},
 numpages = {31},
 url = {http://dl.acm.org/citation.cfm?id=2017212.2017217},
 acmid = {2017217},
 publisher = {Society for Information Management and The Management Information Systems Research Center},
 address = {Minneapolis, MN, USA}
}

Updated Example:

\documentclass[a4paper]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[natbib=true]{biblatex}
\addbibresource{complete}


\begin{document}

    \citep[S.~15]{Hevner2004}
    \bibliographystyle{natdin}

\end{document}
  • 1
    your document is marked up for classic bibtex use not biblatex+biber so for biber no bibliography has been defined, just use bibtex and it should work fine – David Carlisle Jan 16 '17 at 19:49
  • 1
    If you want to use a BibTeX style, use BibTeX. Biblatex cannot use natdin.bst. It does not use .bst files at all and \bibliographystyle{} does zilch. If you want to use Biblatex, you need to specify the style etc. when loading the package. Then use \printbibliography in the document where you want the bibliography. Ifnatdin does what you need and you don't need anything unsupported by BibTeX, that is by far your most straightforward option. – cfr Jan 17 '17 at 0:48
  • The problem is solved, my mistake or the problem was, Im using TeXStudio and you can configure the tools there and the tool was set to biber instead of bibtex, i changed that, now everything works fine. I still want to thank you everyone of you for helping me :) – RawMVC Jan 17 '17 at 3:10
  • Nevertheless, note, \addbibresource needs the file name inclusive the extension, so \addbibresource{complete} should be replaced by \addbibresource{complete.bib}. – Schweinebacke Jan 17 '17 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.