1

I spent my morning trying to solve this problem and reading those previous questions

How to use Xindy with MiKTeX?

makeglossaries call to xindy failed

How to configure TexStudio editor to use Xindy?

But the generation of my glossary with the glossaries package still fails.

I've figured out that if I open a terminal from TeXStudio it cannot find xindy

xindy not recognized

But if I manually open a Terminal I can manually compile my document :

enter image description here

And then I can run pdflatex again and the glossary works.

Here are my options inside TeXStudio :

Meta-compilations: enter image description here

Compilations: enter image description here

Here's my MWE:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[xindy]{glossaries}

\makeglossaries

\newglossaryentry{latex}
{
    name=latex,
    description={Is a mark up language specially suited 
    for scientific documents}
}

\newglossaryentry{maths}
{
    name=mathematics,
    description={Mathematics is what mathematicians do}
}


\begin{document}

The \Gls{latex} typesetting markup language is specially suitable 
for documents that include \gls{maths}. 

\printglossaries

\end{document}

P.S. : I've uninstalled and reinstalled Perl, MikTeX as well as TeXStudio just to make sure that it wasn't a version issue.

I realize this problem is very similar to the questions posted above but I don't know what I can do at this point.

Thanks.

  • Does it work if you give the absolute path to xindy in the texstudio preferences? – user36296 Jan 17 '17 at 18:27
  • @samcarter I'm not sure what you mean, Isn't that what I did with the line "C:/Program Files/MiKTeX 2.9/miktex/bin/x64/texindy.exe" %.idx ? – Luc Rebillout Jan 17 '17 at 19:38
1

Configure Makeglossaries as follows: enter image description here

Here is the result: enter image description here

  • It worked but I still had to add C:\Perl64\bin;C:\Program Files\MiKTeX 2.9\miktex\bin\x64 to the $PATH as shown in my answer. At least we know what's wrong. I'm marking your answer as the answer to my question. – Luc Rebillout Jan 17 '17 at 20:10
  • I don't think installing perl is necessary (I don't have it): MiKTeX has its own runperl.exe. As to the path to the bin directory of MiKTeX, I don't understand why you had to add it to your path: it is automatically added at installation. – Bernard Jan 17 '17 at 20:24
  • I don't understand it either and a neat explanation would be welcome but right now if it works it's all that matters to me :) – Luc Rebillout Jan 17 '17 at 20:39
0

I added C:\Program Files\MiKTeX 2.9\miktex\bin\x64 to the $PATH as well as the Perl directory and now it works. It seems like a dirty solution but at least it works! I'll wait a little while before marking this answer as the answer for this problem just in case someone finds something cleaner.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.