11

I am trying to prepare my article with the new ACM template available Here. When I compile I get the following errors everytime. That means, that these commands are not recognized by tex or the class file which they are calling acmart.dtx is not linked properly.

Errors:

! Undefined control sequence.
l.18 \acmDOI 
            {10.475/123_4}
The control sequence at the end of the top line

There are many such errors. Kindly, help me.

Edits:

I downloaded the zip file from the link pointed above. Then I extracted the files to the acmart folder. It contained acmart.dtx, and few other tex files for sig conferences, journals and the file sigconf.tex.

Now, I compiled the sigconf.tex file to get the errors specified above.

enter image description here

  • Can you provide a complete MWE example? I do not have problems with the new acmart class. – Guido Jan 18 '17 at 8:04
  • 11
    You should first of all unpack the files. Do tex acmart.ins. – egreg Jan 18 '17 at 8:21
  • @Guido Is the acmart.dtx a class file. It has been used like this: \documentclass[sigconf]{acmart} But, there is no acmart.cls file. Should I download it from other source. – Coder Jan 18 '17 at 9:21
  • 3
    Do what egreg said. – Johannes_B Jan 18 '17 at 17:59
  • 1
    @egreg Thank you. It worked! I did tex acmart.ins – Coder Jan 18 '17 at 18:24
10

OSX 10.11 here. Running tex acmart.ins using TeXShop fails with errors. Fortunately, I found the missing acmart.cls file on the SIGPLAN website:

http://www.sigplan.org/sites/default/files/acmart/current/acmart.cls

I wonder why ACM didn't include it in the zip archive.

  • 5
    It is automatically generated after compiling ins file. Tex acmart.ins – Coder Mar 11 '17 at 12:44
  • 1
    In case for whatever reason tex is not available as command, for instance when using ShareLateX, this is the only viable way. – mommi84 Mar 12 '17 at 13:50
  • @Coder but it doesnt work for me. WinEdt still looks for acmart.cls – lonesome Jun 28 '17 at 3:51
2

I got a similar variety of errors, including an error for the \orcid line. My solution included one extra step.

I followed the directions of the comments and run tex acmart.ins. The errors persisted. But! If I then delete all the files of the form sample-sigconf.* except the sample-sigconf.tex source file would build.

2

acmart is distributed also on CTAN and as package for MiKTeX and also for TeX Live. So you should use the package manager of your TeX distribution to install it. The default installation of vanilla TeX Live 2017 already contains acmart. If you have not used the default installation, you can use

tlmgr install acmart

to install it. If only root can install packages, you need

sudo tlmgr install acmart

For MiKTeX use the MiKTeX package manager.

0

I also just had the same problem and I get several Undefined control sequence errors when I build&view the sample-sigconf.tex in Ubuntu with Textstudio. It turns out that samplebody-conf.tex contains some figures with the command \Description, like:

\begin{figure}\includegraphics{fly}\Description{A fly}\caption{A sample black and white graphic.}\end{figure}.

The \Description command was not recognized. I tried executing tex acmart.ins in the command line and removing the sample-sigconf.* files as suggested above, but nothing worked. The example images are provided both in eps format to work with Latex and pdf format to work with Pdflatex. I tried different build commands chains, and I realized that DVI->PS and PS->PDF actually overlooked the \Description command and building the tex file worked.

As a solution, I just removed all descriptions, since they are not necessary for the figures and captions are enough. The ACM template was updated on November 11th 2018, which might have introduced this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.