5

I have tried this with the font "Charis SIL", "Times" and "Times New Roman":

\documentclass[a5paper]{article}

%\usepackage[utf8]{inputenc}
%\usepackage[LGR,T1]{fontenc}
\usepackage[greek,british]{babel}

\usepackage{fontspec}
\setmainfont{Charis SIL}

\begin{document}

This is a simple test. \textgreek{ὅθεν ὤφειλεν κατὰ πάντα}. And orgé as well.

Without slash textgreek ἱλαστήριον (hilasterion)

\end{document}

The é appears in the PDF when using xelatex, but the greek does not, no matter which font I use, and the Charis SIL font should have these characters, they work in other programs with this font. This is what I get in the logs, perhaps I am not setting the front properly? Any tips would be much appreciated.

LaTeX Font Warning: Font shape `LGR/CharisSIL(0)/m/n' undefined
(Font)              using `LGR/cmr/m/n' instead on input line 15.

Missing character: There is no ὅ in font grmn1000!
Missing character: There is no θ in font grmn1000!
Missing character: There is no ε in font grmn1000!
....
Missing character: There is no ἱ in font Charis SIL/OT:script=latn;language=DFLT;mapping=tex-text;!
Missing character: There is no τ in font Charis SIL/OT:script=latn;language=DFLT;mapping=tex-text;!

enter image description here

  • 1
    Don't load fontenc. – cfr Jan 19 '17 at 3:31
  • Commenting out fontenc, but sadly it doesn't help. – Jacob Jan 19 '17 at 3:49
  • 1
    Doesn't help how? It will avoid the problem you posted warnings from. – cfr Jan 19 '17 at 3:50
  • 1
    Yes, but the warnings tell you why nothing appears. However, I'm afraid I'd forgotten that greek Babel does this. You need to drop Babel and use Polyglossia instead. Or redefine all the stuff in greek.ldf that use LGR encoding, which you don't want. But that would be a PITA so just use Polyglossia. – cfr Jan 19 '17 at 4:10
  • 1
    It is specific to Greek, as far as I know. Babel generally works fine with fontspec etc. and Polyglossia is an alternative. But Babel's Greek support won't work with the modern engines and fontspec because the language files enforce a non-unicode encoding. – cfr Jan 20 '17 at 1:16
4

You need something like this, although this is not quite right. At least, it doesn't quite work for me because Charis SIL does not support Greek. At least, the version I have does not:

otfinfo -s /usr/share/fonts/ttf-charis-sil-ibx/CharisSIL-R.ttf 
DFLT            Default
cyrl            Cyrillic
cyrl.SRB        Cyrillic/Serbian
latn            Latin
latn.IPPH       Latin/Phonetic transcription—IPA conventions
latn.VIT        Latin/Vietnamese

However, if you substitute a suitable font, it should work fine.

\documentclass[a5paper]{article}

\usepackage{polyglossia}
\setmainlanguage[variant=british]{english}
\setotherlanguage{greek}
\usepackage{fontspec}
\setmainfont{Charis SIL}
\newfontfamily\greekfont{Charis SIL}

\begin{document}

This is a simple test. \textgreek{ὅθεν ὤφειλεν κατὰ πάντα}. And orgé as well.

Without slash textgreek ἱλαστήριον (hilasterion)

\end{document}
  • I've been working on this for hours trying to get it to work, this is perfect. — Regarding Charis SIL, this is confusing, this font is explicitly designed for printing these characters, and works in other apps. I wonder why it doesn't work in latex. – Jacob Jan 19 '17 at 4:27
  • @Jacob Well it says that it does not support Greek. The fact that it has the characters is irrelevant. It doesn't support Greek script. – cfr Jan 20 '17 at 1:14
6

Strictly speaking Charis SIL was designed for Latin and Cyrillic scripts. See the FAQ: Why does the font have some Greek characters, but not all?:

While it is true that the font includes some Greek characters, it is not intended to provide general support for the Greek language. Those Greek characters that were included were done so in order to support various (primarily linguistic) notational systems. If Greek language support is needed, the Galatia SIL and Gentium fonts are two available options.


For what it's worth, I also like GFS Artemisia:

\documentclass[a5paper]{article}
\usepackage{fontspec}
\setmainfont{Charis SIL}
% \newfontfamily\greekfont{Charis SIL}
\newfontfamily\greekfont[Scale=MatchLowercase]{GFS Artemisia}

\usepackage{polyglossia}
\setmainlanguage[variant=british]{english}
\setotherlanguage[variant=polytonic]{greek}

\begin{document}

This is a simple test. \textgreek{ὅθεν ὤφειλεν κατὰ πάντα}. And orgé as well.

% note: the Greek will fail here because you are not using \greekfont (and Charis SIL doesn't have the characters)
Without slash textgreek ἱλαστήριον (hilasterion)

\end{document}
  • Thanks, my memory from the time I download this font, is obviously somewhat faulty. Thanks. – Jacob Jan 19 '17 at 5:47
  • @Jacob -- Cheers. I had the same belief, too, though I can't remember where it came from now.... – jon Jan 19 '17 at 5:51
  • This will get you American English rather than British, as in the original MWE, I believe. – cfr Jan 20 '17 at 1:17
  • @cfr -- yes, very true. Fixed. It was not my intention to privilege, tacitly American hyphenation..! – jon Jan 20 '17 at 1:33
  • @jon ;) Can't upvote again, mind :(. – cfr Jan 20 '17 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.