1

I installed texlive-full in my unbutu 14.04 64 bit by the command

sudo apt-get install texlive-full

It is installed in the folder /usr/share/texlive. Then I download texstudio.deb and install it. After install, I open a .tex file, build it and got the error.

Make sure that you have installed a (La)TeX distribution e.g. MiKTeX or TeX Live, and have set the correct paths to this distribution on the command configuration page. A (La)TeX editor like TeXstudio cannot work without the (La)TeX commands provided by such a distribution.

enter image description here

I opened the configure path but I don't know how to set them. Please help me to fix it. Thanks all

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. A suggestion: Do us a favour and change your username to something more telling than "user1234". – Martin Schröder Jan 20 '17 at 6:35
  • Exactly which texstudio version is this? I have texstudio on my box (though I don't use it, and it works with out problems). – daleif Jan 20 '17 at 7:47
  • Thank daleif. I am installing the last version of texstudio amd64 2.12.0, QT 4 15 MiB – John Jan 20 '17 at 8:09
  • I'm guessing this is an error in texstudio. You are not the first with this problem. I can confirm that after purging the texstudio I had from Ubuntu, removing the existing configuration (I should have renamed it...) and installing TS 2.12.0 from the website, I get the same problem. I would report this to the developers. – daleif Jan 20 '17 at 8:36
  • I downgraded to 2.11 (just follow the link for ubuntu 14.04 packages, there are older versions on that site. This version works. The commands pane is filled in. – daleif Jan 20 '17 at 8:46
4

Too long for a comment. This is what that image with the build commands normally looks like (this is from TS 2.11)

enter image description here


Instead of typing this by hand, one could just install TS 2.11, and use it. This has the correct build informations. Then purge TS 2.11 and install TS 2.12. Purging does not delete your local TS configuration, and voila, they survive for TS 2.12.

Even further, here is the Tools/Commands list from the generated texstudio.ini from my system

Tools\Commands\asy=asy ?m*.asy
Tools\Commands\asy-dvi-chain=txs:///latex | txs:///asy | txs:///latex | txs:///view-dvi
Tools\Commands\asy-pdf-chain=txs:///pdflatex | txs:///asy | txs:///pdflatex | txs:///view-pdf
Tools\Commands\biber=biber %
Tools\Commands\bibliography=txs:///bibtex
Tools\Commands\bibtex=bibtex %.aux
Tools\Commands\bibtex8=bibtex8 %.aux
Tools\Commands\compile=txs:///pdflatex
Tools\Commands\dvi-chain=txs:///latex | txs:///view-dvi
Tools\Commands\dvi-pdf-chain=txs:///latex | txs:///dvipdf | txs:///view-pdf
Tools\Commands\dvi-ps-pdf-chain=txs:///latex | txs:///dvips | txs:///ps2pdf | txs:///view-pdf
Tools\Commands\dvipdf=dvipdf %.dvi
Tools\Commands\dvipng=dvipng -T tight -D 120 %.dvi
Tools\Commands\dvips=dvips -o %.ps %.dvi
Tools\Commands\glossary=txs:///makeglossaries
Tools\Commands\gs=gs \"?am.ps\"
Tools\Commands\index=txs:///makeindex
Tools\Commands\internal-pre-compile=txs:///pre-compile | txs:///conditionally-recompile-bibliography
Tools\Commands\latex="latex -src -interaction=nonstopmode %.tex"
Tools\Commands\latexmk="latexmk -pdf -silent -synctex=1 %"
Tools\Commands\lualatex="lualatex -synctex=1 -interaction=nonstopmode %.tex"
Tools\Commands\makeglossaries=makeglossaries %
Tools\Commands\makeindex=makeindex %.idx
Tools\Commands\metapost="mpost -interaction=nonstopmode ?me)"
Tools\Commands\pdf-chain=txs:///pdflatex | txs:///view-pdf
Tools\Commands\pdflatex="pdflatex -synctex=1 -interaction=nonstopmode %.tex"
Tools\Commands\pre-compile=
Tools\Commands\ps-chain=txs:///latex | txs:///dvips | txs:///view-ps
Tools\Commands\ps2pdf=ps2pdf %.ps
Tools\Commands\quick=txs:///compile | txs:///view
Tools\Commands\recompile-bibliography=txs:///compile | txs:///bibliography | txs:///compile
Tools\Commands\svn="svn "
Tools\Commands\svnadmin="svnadmin "
Tools\Commands\texindy=texindy %.idx
Tools\Commands\view=txs:///view-pdf
Tools\Commands\view-dvi=xdg-open %.dvi > /dev/null
Tools\Commands\view-pdf=txs:///view-pdf-internal --embedded
Tools\Commands\view-pdf-external=xdg-open %.pdf > /dev/null
Tools\Commands\view-ps=xdg-open %.ps > /dev/null
Tools\Commands\xelatex="xelatex -synctex=1 -interaction=nonstopmode %.tex"
  • Perfect. Thanks daleif. I setting same your above and it worked. – John Jan 20 '17 at 9:38
  • @user8264 here is something easier: Start by installing ST 2.11 and use it to compile a new document. This creates the ST configuration on your system. Then purge it and install ST 2.12. The purging does not delete your local TS configuration and this is then used by TS 2.12 – daleif Jan 20 '17 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.