0

Untill yesterday I had worked with Word, but my instructor recommended I start using LyX. I use windows, so I followed the wiki he recommended. Everything runs alright except when trying to compile to pdf, I recieved the error:

LaTeX Error: File `cp1255.def' not found.

It's worth mentioning that I tried to uninstall and install the 2.0.6 version, but got the same error, so I reinstalled 2.2.2.

How can I fix this? Thanks in advance.

Here is the log file for trying to compile a document with hebrew:

This is pdfTeX, Version 3.14159265-2.6-1.40.17 (MiKTeX 2.9.6100) (preloaded format=pdflatex 2017.1.20)  20 JAN 2017 17:01
entering extended mode
**./newfile1.tex
(newfile1.tex
LaTeX2e <2016/03/31> patch level 3
Babel <3.9r> and hyphenation patterns for 75 language(s) loaded.

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\size10.clo"
File: size10.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\fontenc.sty"
Package: fontenc 2016/06/19 v1.99m Standard LaTeX package
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\t1enc.def"
File: t1enc.def 2016/06/19 v1.99m Standard LaTeX file
LaTeX Font Info:    Redeclaring font encoding T1 on input line 48.
)) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\inputenc.sty"
Package: inputenc 2015/03/17 v1.2c Input encoding file
\inpenc@prehook=\toks14
\inpenc@posthook=\toks15
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\latin9.def"
File: latin9.def 2015/03/17 v1.2c Input encoding file
)

! LaTeX Error: File `cp1255.def' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: def)

Enter file name: 
! Emergency stop.
<read *> 

l.158 \endinput

*** (cannot \read from terminal in nonstop modes)


Here is how much of TeX's memory you used:
 449 strings out of 493333
 4397 string characters out of 3136605
 53242 words of memory out of 3000000
 4056 multiletter control sequences out of 15000+200000
 4403 words of font info for 15 fonts, out of 3000000 for 9000
 1141 hyphenation exceptions out of 8191
 23i,0n,19p,144b,37s stack positions out of 5000i,500n,10000p,200000b,50000s
!  ==> Fatal error occurred, no output PDF file produced!
5
  • Can you post a minimal example .lyx file? Do the Hebrew manuals work for you? On Ubuntu, the Hebrew Intro and Tutorial manuals compile fine for me.
    – scottkosty
    Jan 21, 2017 at 3:17
  • @scottkosty When trying to compile the manuals I get the same error. The file I got the log file in the main post contained only "אבג", or something along those lines, nothing more. Jan 21, 2017 at 21:06
  • Do you have the file cp1255.def? If not, then you need to install the package that has it. On Ubuntu, the package "texlive-lang-other" has it. You might try to install the package "babel-hebrew", but I'm not sure how it works on Windows.
    – scottkosty
    Jan 21, 2017 at 21:14
  • @scottkosty Yes, after some fiddling I installed the "babel-hebrew" package through miktex's package manager, and everything works now! Thanks! Jan 21, 2017 at 22:39
  • Glad it worked!
    – scottkosty
    Jan 22, 2017 at 2:30

1 Answer 1

3

On Windows, install the package "babel-hebrew" through MiKTeX's package manager.

On Ubuntu, if you are using TeX Live from the Ubuntu repos, install the package "texlive-lang-other".

On other systems, search for the package that contains the file "cp1255.def".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .