1

Hi and many thanks in advance!

I'm working on a beamer presentation using a theme which shows the title and subsections in the headline. When clicking on the title everything works as expected and I get to the first frame of the presentation. But when clicking on a subsection title, nothing happens. I'd expect to get to the first frame of the current section (where I usually provide a TOC for the current section). What could cause that problem?

MWE:

\documentclass[]{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english,ngerman]{babel}

\mode<presentation>
{
    \usetheme{Montpellier}
    \setbeamertemplate{navigation symbols}{\insertbackfindforwardnavigationsymbol}  
    \setbeamertemplate{caption}[numbered]
}
\title{Title}\author{Author}\date{Date}

\begin{document}
\begin{frame}\titlepage\end{frame}

\begin{frame}{Outline}
\tableofcontents[hideallsubsections]
\end{frame}

\section{Section number one}
\begin{frame}{}\tableofcontents[currentsection,hideothersubsections]\end{frame}
\subsection{Subsection one-one}\begin{frame}{Frame content one-one}\end{frame}
\subsection{Subsection one-two}\begin{frame}{Frame content one-two}\end{frame}

\section{Section number two}
\begin{frame}{}\tableofcontents[currentsection,hideothersubsections]\end{frame}
\subsection{Subsection two-one}\begin{frame}{Frame content two-one}\end{frame}
\subsection{Subsection two-two}\begin{frame}{Frame content two-two}\end{frame}

\end{document}
5
  • 1
    Works for me as expected: upon clicking on the subsection I get to first frame of the SUBsection. Jan 22, 2017 at 23:01
  • @samcarter Doesn't work for me. I'm not referring to the PDF bookmarks or the TOCs in the presentation, these work fine. But for instance, when I'm on page 4 of the MWE just nothing happens if I click the section or subsection title in the header. (The title works and leads to the first page.) Does this work for you? Thanks!
    – Pontis
    Jan 23, 2017 at 9:12
  • Yes, the links in the headline work for me. Two questions: Did you compile 2 times? Which compiler are you using? I tried with pdflatex from texlive 2016. Jan 23, 2017 at 9:31
  • Can you disentangle sections and subsections in your questions? Currently this is a bit confusing. Jan 23, 2017 at 9:33
  • @samcarter Thanks for your efforts, I just found a solution, see my answer.
    – Pontis
    Jan 23, 2017 at 9:56

1 Answer 1

1

I just found a solution, obviously I wasn't searching accurately enough before. That indeed was a bug in beamer version 3.36 that can be solved as described here.

I updated to the quite new versions 3.37/3.38 which were released this month, now everything works fine.

1
  • 1
    On this basis, I've closed the question as a dupe
    – Joseph Wright
    Jan 23, 2017 at 9:57

Not the answer you're looking for? Browse other questions tagged .