4

I am having a really weird Problem, and after 4 hours of googling and trying and failing I hope somebody can help me:

Background Information: I am using texstudio and miktex, my documents are coded in UTF-8

In my document I am using tikz for drawing some trees. Since I am using tikz I was forced to switch from pdflatex to lualatex. Since then all my german umlauts (ÄÖÜ) and the sharp s (?) do not work anymore.

From what I've read in the net, the easiest way to make them working again, is to add \usepackage{fontspec} to my preamble and removing

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

So this is what I did. But then I'm getting a lot of errors like the following:

Font \EU2/lmr/m/n/10=file:lmroman10-regular:script=latn;+trep;+tlig; at 10pt not loadable: metric data not found or bad. \fontencoding\encodingdefault\selectfont

Font \EU2/lmr/m/n/12=file:lmroman12-regular:script=latn;+trep;+tlig; at 12pt not loadable: metric data not found or bad. \normalsize

Font \EU2/lmr/m/n/8=file:lmroman8-regular:script=latn;+trep;+tlig; at 8pt not loadable: metric data not found or bad. \begin{tabular}

Okay... Google told me that it seems that i need to add the package lmodern so I added it: \usepackage{lmodern}. hm... didn't work. Still I am getting the same errors...

Okay, I tried to start a clean document, just to check if the same would happen:

\documentclass[a4paper,12pt,]{scrartcl}
\usepackage[ngerman]{babel}
\usepackage{lmodern}
\usepackage{fontspec}
\begin{document}
    TEST: Ä
\end{document}

And Yes. The Results are the same: enter image description here

So... this is what I tried the last 4 hours and slowly I am getting a little frustrated. I have no Idea \dots

But I hope you can help ;)

closed as off-topic by egreg, Mico, Stefan Pinnow, Martin Schröder, user13907 Jan 24 '17 at 19:35

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Works here with TeXLive 2016. Is your MikTeX up to date? And is latin modern installed? – Martin Schröder Jan 24 '17 at 16:09
  • 3
    Side remark: Don't rely too much on the "Fehler und Warnungen"-Tab. It has a tendency not to show the whole story. Better look in the log-file.# – Ulrike Fischer Jan 24 '17 at 16:21
  • 3
    You probably have a user format. Run the updater also as user, and recreate the format with the user version of miktex settings. Make sure that the lualatex is not excluded in the tab "formats" – Ulrike Fischer Jan 24 '17 at 16:32
  • 2
    Why did you have to switch to lulatex from pdflatex to use tikz? – Herb Schulz Jan 24 '17 at 17:02
  • 4
    I'm voting to close this question as off-topic because the issue was due to outdated software, solved with an update of MiKTeX – egreg Jan 24 '17 at 17:34
3

The answer to my question is very simple and a little bit silly...

My MikTex was just not up-to-date, despite the fact that the current version was downloaded and installed just a few days ago. So if somebody else is running into this problem some day. Here is what you should do:

  1. Run the MikTex Updater (Admin) and Update Miktex itself
  2. Run the MikTex Updater (Admin) again and update all packages (repeat this until the updater tells you that every package is up to date)
  3. Run the MikTex Updater (without Admin) and repeat steps 1&2
  4. Run the MikTex Settings (Admin) and recreate the formats
  5. Run the MikTex Settings (without Admin) and recreate the formats

Thats it. It should work now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.