1

This question already has an answer here:

I am trying to let Latex shorten the authorlist in my bibliography automatically, but it seems to ignore my settings. This is my MWE:

\documentclass{scrreprt}
\usepackage[backend=bibtex, maxnames=2,style=numeric-comp]{biblatex}
\addbibresource{Literatur.bib}
\begin{document}

This is testing text...
\cite{Huebler2011}
\cite{Pierre2015}

\printbibliography
\end{document}

This gives me following result:

enter image description here

As you can see, the selected style is applied, but all authors appear in the bibliography list. I am using TeXnicCenter with MikTex 2.9.

I get one warning message after compilation, which reads Package Biblatex Warning: Using fall-back BibTeX(8) backend. I did some online search on that too, as it seems related to the problem, but haven't found anything helpful. Not specifieing a backend does not generate a bibliography at all.

I hope this doesn't turn out to be a stupid newbie mistake, but could very well be. Any help is greatly appreciated.

marked as duplicate by moewe biblatex Jan 25 '17 at 15:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The options should actually work. If the screen shot you show us comes from the exact MWE you posted, the problem might lie with the .bib file. You need to separate names with an and in the author list and not with a semicolon, see tex.stackexchange.com/q/557/35864 – moewe Jan 25 '17 at 14:14
  • Thank you very much, that helped. I thought I'd get noticed by my IDE if I mess up the separators and such. Can't upvote comments, but you Sir saved my day. – MrHoessi Jan 25 '17 at 14:50
  • I'd expect BibTeX/Biber to complain about the name format, but I'm not sure what BibTeX actually has to say in these instances. And then it is still an issue of how your IDE reports these things if they are no errors that stop the document from compiling properly. – moewe Jan 25 '17 at 15:24