6

I'm using the libertinus font in order to match the math to my text (i used linux libertine). I need a \mathcal{L} symbol in my text, but i'm only getting a regular L. I looked at the documentation of the font and compiled the .tex document myself. I get a different output, however. Here is a passage using \mathcal{A} in the uploaded pdf-file: Image of uploaded pdf

here is an image of the same passage in the document i compiled myself: Image of self-compiled document

As you can see, there is clearly a difference.

I'm confused. I wanted to find a difference in my preamble to the documentation, but even the documentation (using the exact same .tex file) gives me different results. I have no idea how to fix this, i don't know much about font handling. Note that this could be my only issue, so having a special treatment of \mathcal{L} would be fine (though i would love to learn more about the difference here).

Here is a MWE taken from the linked .tex file:

\documentclass{article}

\usepackage{amsmath,amsthm,trace}
\usepackage{unicode-math}
\setmainfont{Libertinus Serif}
\setsansfont{Libertinus Sans}
\setmathfont[AutoFakeBold]{Libertinus Math}

\newtheorem{thm}{Theorem}[section]
\newtheorem{lem}[thm]{Lemma}

\newcommand{\A}{\mathcal{A}}
\newcommand{\BB}{\mathcal{B}}

%    Enclose the argument in vert-bar delimiters:
\newcommand{\envert}[1]{\left\lvert#1\right\rvert}
\let\abs=\envert

\begin{document}
    \begin{lem}\label{p0201}
    Let $\A$ be an arrangement. Then
    \[ \chi (\A,t) = \sum_{\BB \subseteq \A}
    (-1)^{\abs{\BB}} t^{\dim T(\BB)}. \]
    \end{lem}
\end{document}
  • Why not adding the .tex file here? I don't like following external links just to fetch some code... – user31729 Jan 25 '17 at 16:38
  • Sorry, i added a MWE. I took the documentation file an stripped everything not needed. – pschulz Jan 25 '17 at 16:51
  • I've used your MWE and I get the output you have shown in the first image, i.e. the desired one – user31729 Jan 25 '17 at 16:54
  • Hm, this is strange. Unfortunately, adding \usepackage[libertine]{newtxmath} didn't help. – pschulz Jan 25 '17 at 16:58
  • My suggestion was an error. I confused libertine with libertinus. I've removed my comment – user31729 Jan 25 '17 at 16:59
7

The font on CTAN seems to be faulty. You need to download the newest version from github https://github.com/khaledhosny/libertinus/blob/master/libertinusmath-regular.otf and either replace your font or move it e.g. to your current folder and load it with

  \setmathfont{libertinusmath-regular.otf}[Path=./]
  • 1
    And, if using LuaTeX, you might need to refresh luatex-cache when you replace an existing font file with a newer version. – user103221 Jan 25 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.